Tensorflow installation on Jetson TX1 (24.1)

I’ve been trying various ways using docker, bazel build and cmake to build tensorflow:
Not much success, I’m wondering if there is a good way to have tensorflow c++ library build on Jetson TX1 with 24.1 system?
I’ve seen it is successfully built in other systems such as 28.x, but there’s something different.

Please let me know if there is any way to get tensorflow c++ library built on Jetson TX1 (24.1)!

Thank you a lot!

Hi,

Do you mean rel-24.2.1 from JetPack-2.3.1?
If yes, here is a tutorial from Jetsonhacks:
https://www.jetsonhacks.com/2016/12/30/tensorflow-nvidia-jetson-tx1-development-kit/

Thanks.

Thank you very much for your reply!
I want to try it out!

Do you know a good way to make the Jetson compile tensorflow using external disk space, the disk space does not have too much space.

Thank you!

You can always mount an ext4 formatted partition (e.g., SD card or SATA disk or thumb drive) somewhere like “/usr/local/” and have all of that go to the new drive.

I tried to move /usr to another drive, but I did not keep necessary files in the /usr so now the ubuntu won’t boot.
Could you let me know how I can recover the /usr directory?
I don’t know the root password.

Thank you very much!!

Do you need to recover what you have now? If not, then it is easiest to just flash and not worry about it. If your Jetson was not already at a recent version (e.g., R28.2), then a flash might be appropriate anyway.

If you need to save what is there, then you can clone. The procedure might change depending on current release, but see this:
https://devtalk.nvidia.com/default/topic/898999/jetson-tx1/tx1-r23-1-new-flash-structure-how-to-clone-/post/4784149/#4784149
https://devtalk.nvidia.com/default/topic/1005936/jetson-tx1/tx1-flash-problem/post/5135740/#5135740

If you do clone, then the produced file with “.img” extension is only useful for restore, and since it would need to be edited (yet “.img” from clone is not editable), this could be deleted. Clone also produces a “.img.raw” file, and this is the one you can loopback mount, copy, edit, expore, and even use to flash the TX1 after editing (but your Jetson would need to use the same flash software version as the Jetson root file system uses).

Do you need to clone or save? If not, then probably just flash the most recent R28.2 from here:
https://developer.nvidia.com/embedded/linux-tegra-r282

Btw, it is fairly safe to relocate anything on “/usr/local/”, but “/usr” has content used during boot and thus if boot must be complete in order to get tools for boot, there is a problem. You’d end up needing an initrd which isn’t used by default in current releases.

Thank you!
I’m flushing the new release linux-tegra-r282, and the host ubuntu’s ethernet stopped working while installing the system to Jetson, specifically, while installing cuda to /var/cuda-repo-9.0-local. The host ubuntu suddenly having trouble connecting to to http://ports.ubuntu.com/ubuntu-ports xenial Release:

Temporary failure resolving 'ports.ubuntu.com'

And then I have trouble connecting the host to the internet via eth0.

Could you give me some insight on this!

Thank you!!

Flash is separate from package addition. Flash occurs purely over the micro-USB port in recovery mode. Once flash completes JetPack will then try to talk to the Jetson over wired ethernet (don’t use WiFi). There is a bit of a hack in place such that a freshly flashed Jetson will try to report its IP address to the host. Should this fail, then the next reboot won’t do this, and you will have to enter the IP address manually (watch the console messages in JetPack…you can disable flash and run JetPack at any time for package addition without flashing again).

Wired ethernet is set up for DHCP, meaning either your host PC or the router will be assigning an address. If you log in locally to the Jetson (e.g., GUI, console, or serial console), then “ifconfig” should show the IP address on eth0 of the Jetson.

There are many people in regions where the internet has filtering or proxy, and you must adjust for this since JetPack itself downloads packages over the internet before placing them on the Jetson. Firewalls, lack of DNS setup, and proxies all can get in the way. The “ports.ubuntu.com” resolving issue tends to say DNS does not have knowledge of this outside internet domain.

I got the JetPack 3.3 installed, I got it solved by restarting the internet manager.

Thank you for your help!!