Tensorflow is not upgrading

Hello All,
I installed tensorflow-gpu on my jetson TX2 from
$: pip install --extra-index-url https://developer.download.nvidia.com/compute/redist/jp33 tensorflow-gpu
and I have tf-gpu 1.9.0
but I want tf-gpu 1.12.0

I tried (pip3 install --upgrade tensorflow-gpu) but it says requirements already up to date and already satisfied

I tried (pip3 install --upgrade tensorflow-gpu==1.12.0) it says couldn’t find a version that satisfies the requirement tensorflow-gpu==1.12.0 error: no matching distribution found for tensorflow-gpu==1.12.0

I’m on Jetson TX2, ubuntu 16.04, cuda 9, python 3.5.2

any suggestions?


It looks like that documentation is from an old version of the installation guide. Following the updated documentation here: https://docs.nvidia.com/deeplearning/frameworks/install-tf-jetson-platform/index.html should solve your problem. The main issue is that only specific TensorFlow and JetPack version combinations are supported, and the version of JetPack you’re on (which seems to be 3.3 based on the old documentation) doesn’t currently have a supported release of TensorFlow 1.12.

I would recommend upgrading to the latest JetPack version 4.2 using SDKManager available here: https://developer.nvidia.com/embedded/jetpack and then you’ll have access to the latest TensorFlow.

Thanks for your post!
Matt Conley

thank you for your replay, bare with me a little bit I’m a beginner

by upgrading to the newest JetPack 4.2, this means flashing the Jetson again and removing all my data and files?

and can I download tensorflow 1.12 without upgrading by using anaconda or build it by source?


Flashing to the new version of JetPack would mean removing the data and files local to your device, so if you have anything there you’d want to keep I would recommending backing it up to an external drive.

Unfortunately, there is not a pre-built TF 1.12 wheel compatible with JetPacks 3.3 or 4.2, so a more manual build/installation for that release is necessary. However, by upgrading to JetPack 4.2 you will be able to install and use TF 1.13.1, which is a more current version of the software.

Is there a specific reason you’d prefer to use 1.12 instead of 1.13, or are you just trying to use a more recent release than 1.9? TF 1.13 should have whatever you need, I’d be curious to know if that wasn’t the case.

Matt Conley

update : I had a code that only works with tf 1.12 but jetpack 3.2 has tf 1.9 thats why i wanted to upgrade to tf 1.12 but know i have found the same code in archive that works with tf 1.9 so all good.