TensorRT 5 for Ubuntu 16 and CUDA 9 is incompatible with Python 3.6

The file TensorRT 5.0.0.10 RC for Ubuntu 16.04 and CUDA 9.0 tar package contains a Python wheel file that doesn’t contain TensorRT shared library for Python 3.6 (only 2 and 3.5), though it’s included in the tar package for Ubuntu 18 and CUDA 10. Could you make a single common wheel file for all Pythons?

There is also no TAR package for Ubuntu 18 and CUDA 9, so how can we use TensorRT 5 with TensorFlow (which requires CUDA 9.0)?

Thanks for any help.

Regards,
Adam

Thank you for your feedback regarding TensorRT5 RC. We are discussing version-agnostic wheels for GA. Sorry again that we cannot share more information about future release here. Please pay attention to future announcement.

Hello,

Regarding no CUDA 9 tar on Ubuntu 18.04, this is due to a technical issue. Ubuntu 18.04 is using GCC 7.3.0 (https://docs.nvidia.com/deeplearning/sdk/tensorrt-support-matrix/index.html#software-version-platform) which is not supported by CUDA 9.

Thank you for your reply. So, our only hope is a Python 3.6-compatible wheel for Ubuntu 16 and CUDA 9.

Hello,

version-agnostic wheels are scheduled for the release after 5 GA. Apologies for any inconvenience this may have caused. We receive many community requests and are always prioritizing. Sorry again that we cannot share more information about further release here. Stay tuned for our future announcement.