tensorrt requires argparse

Hi, guys.
I have installed tensorrt 3.0.4 but when I try to make an installation of tensorflow using tensorrt 3.0.4, I got the following:

uff 0.2.0 requires argparse>=1.4.0, which is not installed.
tensorrt 3.0.4 requires argparse>=1.4.0, which is not installed.

But the strangeness is that pip show argparse produce the following output:

Name: argparse
Version: 1.4.0
Summary: Python command-line parsing library
Home-page: https://github.com/ThomasWaldmann/argparse/
Author: Thomas Waldmann
Author-email: tw@waldmann-edv.de
License: Python Software Foundation License
Location: /root/env/py3/lib/python3.5/site-packages
Requires: 
Required-by: uff, tensorrt

Seems like tensorrt and uff can’t find argpase, while they are also in root/env/py3/lib/python3.5/site-packages

pip show tensorrt
Name: tensorrt
Version: 3.0.4
Summary: Python API for TensorRT, a high-performance deep learning inference optimizer and runtime for deep learning applications.
Home-page: https://developer.nvidia.com/tensorrt
Author: cudatools
Author-email: cudatools@nvidia.com
License: NVIDIA Software License
Location: /root/env/py3/lib/python3.5/site-packages
Requires: enum34, future, protobuf, argparse, numpy, pycuda, Flask, pillow
Required-by:

How can I fix that?

Fixed: the problem was related to a wrong version of pip. Don’t use pip > 9.0

We created a new “Deep Learning Training and Inference” section in Devtalk to improve the experience for deep learning and accelerated computing, and HPC users:
https://devtalk.nvidia.com/default/board/301/deep-learning-training-and-inference-/

We are moving active deep learning threads to the new section.

URLs for topics will not change with the re-categorization. So your bookmarks and links will continue to work as earlier.

-Siddharth