Terminate called after throwing an instance of 'std::logic_error' what(): basic_string::_M_construct null not valid

Loaded a pre-trained Tensorflow UNET model on AGX Xavier for inference, but got an error and core dump @“model.predict()”. Worked fine on Servers with Tensorflow 2.1 & 2.3 installed. However, a pre-trained PyTorch model worked fine.

error.txt (10.1 KB)

NVIDIA Jetson AGX Xavier [16GB]
L4T 32.4.2 [ JetPack 4.4 DP ]
Ubuntu 18.04.4 LTS
Kernel Version: 4.9.140-roscube.v0.1
CUDA 10.2.89
CUDA Architecture: 7.2
OpenCV version: 4.1.1
OpenCV Cuda: NO
CUDNN: 8.0.0.145
TensorRT: 7.1.0.16
Vision Works: 1.6.0.501
VPI: 0.2.0

Hi,

Could you try our latest JetPack4.4.1 first?

There are some bugs fixed in our latest release.
One of them has a similar error log as yours.

Thanks.

Hi AastaLLL,
Thanks for the prompt reply.
I used Nvidia’s guide line to upgrade JetPack on my AGX Xavier from 4.4 to 4.4.1, but did not go well.
Looks like I have to resolve the upgrade issues before I can try out the latest JetPack release.
Do I need to open another ticket for this upgrade issue?

Thanks,

  1. Tried “apt depends nvidia-jetpack | awk ‘{print $2}’ | xargs -I {} sudo apt install -y {}”
    get the following error messages:
    The following packages have unmet dependencies:

nvidia-l4t-jetson-multimedia-api : Depends: nvidia-l4t-camera (= 32.4.4-20201027211332) but 32.4.2-20200408182620 is to be installed

                                Depends: nvidia-l4t-multimedia (= 32.4.4-20201027211332) but 32.4.2-20200408182620 is to be installed

                                Depends: nvidia-l4t-multimedia-utils (= 32.4.4-20201027211332) but 32.4.2-20200408182620 is to be installed

E: Unable to correct problems, you have held broken packages.

  1. Tried install SDK manager got the following messages:
    ros@ROScube-X:~/Downloads$ sudo apt install ./sdkmanager_1.3.1-7110_amd64.deb

Reading package lists… Done

Building dependency tree

Reading state information… Done

Note, selecting ‘sdkmanager:amd64’ instead of ‘./sdkmanager_1.3.1-7110_amd64.deb’

Some packages could not be installed. This may mean that you have

requested an impossible situation or if you are using the unstable

distribution that some required packages have not yet been created

or been moved out of Incoming.

The following information may help to resolve the situation:

The following packages have unmet dependencies:

sdkmanager:amd64 : Depends: libgconf-2-4:amd64 but it is not installable

                Depends: libcanberra-gtk-module:amd64 but it is not installable

                Depends: locales:amd64 but it is not installable

E: Unable to correct problems, you have held broken packages.

ros@ROScube-X:~/Downloads$

Hi,

Could you try to use SDKmanger for the upgrade first?
Pleaes noted that SDKmanager is launched on a desktop environment and connects to XavierNX with a type-c.

Thanks.

The online instruction uses a Linux PC, I do not have a Linux desktop at the moment. May take some more time.

Thanks,