Tesla C2070 device query error

I recently installed the tesla C2070 on my dell precision 5600. I Installed it and downloaded the cude 6.0 package. I have been trying to run the precompiled deviceQuery.exe and I am getting an unknown error code (30) returned from cudaGetDeviceCount. Also the device is showing up in my windows device manager as functioning. My OS is windows 7 64-bit.

I’ve done a clean install of the drivers, and no improvement. Any ideas? I thought maybe a power issue since I only have a 625 W power supply.

what is the result of running

nvidia-smi -a

from an elevated command prompt?

It says:
Nvidia-SMI has failed because you are not:
a)running as an administrator or
b)there is not at least one TCC device in the system

Yes, when I asked you to run from an elevated command prompt, that means a command prompt that is being run as administrator. Go to the windows start menu, find the command prompt entry, right-click on it, and select run as administrator. THen run nvidia-smi

Sorry about that, I’m really more of a unix user, which is probably part of my problem getting this sorted out on my PC.

It said: Failed to initialize NVML: Unknown error

Almost as enlightening as my other error!

The driver is not installed correctly. Are there other NVIDIA GPUs in the system besides the C2070?

I suggest you download an appropriate driver for that C2070, separately, such as this one:

http://www.nvidia.com/download/driverResults.aspx/75455/en-us

When you install that driver, select a “clean install”, following the instructions here:

http://nvidia.custhelp.com/app/answers/detail/a_id/2900/~/guide-on-how-to-install-the-nvidia-display-driver-under-windows-7%2Fwindows-vista

and then re-run the nvidia-smi test.

I did the clean install, and the installer said everything was installed and I had to restart. I tried again as administrator and I received the same error message.

Are there other NVIDIA GPUs in the system besides the C2070? Do you hve the necessary additional power cords plugged into the C2070?

No other GPU’s.

And my power supply only has one 6-pin connector, which I was worried about. However I thought that if this was the issue the GPU wouldn’t show up as working properly in the device manager. I’ve tried it in both the 6 and 8 pin slots just to make sure.

You need either an 8-pin cable in the 8-pin socket, or else two 6-pin cables, one plugged into the 6-pin socket, and one plugged into the 8-pin socket. One 6-pin cable is not sufficient.

My power supply has an 8 pin connector on the supply, but the other end of the cable is 6-pin. There isn’t another socket for another cable. Anyway I have ordered a 825-watt supply that has an additional socket but may try to find an 8-pin cable and give that a try in the interim.

My PSU board has an 8-pin socket, the same as the Tesla device. Currently it has a female-to-female 8-pin to 6-pin connector. It looks like to get my GPU to work I need an 8-pin to 8-pin. After scouring the internet such a thing seems not to exist. Any tips on finding this rare beast?

If by PSU, you mean your physical power supply. I would not try to hook up a direct connection from an 8-pin molex type connector on the power supply to the Tesla C2070 – the pinouts from the power supply output probably do not match the PCI-E power pinout.

See: http://www.tomshardware.com/reviews/power-supply-specifications-atx-reference,3061-12.html

If you still need clarification after reading the article above, you may post the manufacturer/model # of the power supply you have now (assuming this is not the one you purchased and are waiting for) to make it easier to see what exactly you’re working with and possibly provide a solution.

The power supply itself is a F635EF-00 (the old one). The old one and the new one slide out and plug into the PSU board that has power connections for the drives, motherboard as well as an 8-pin connector labeled ‘VGA_1’ that looks like PCI-E configuration based on the document above.

.

Okay, that’s not your usual power supply, and thus why I was getting a bit confused. This document puts it in perspective: ftp://ftp.dell.com/Manuals/all-products/esuprt_desktop/esuprt_dell_precision_workstation/precision-t5600_Owner’s%20Manual_en-us.pdf

Page 27 shows the board you mention, and yes, that would presumably have the correct pinout. Also, this document mentions that the single 8-pin PCI-E connector might be enough to power the C2070:
http://www.nvidia.com/docs/IO/43395/Tesla_C2050_2070_IG_September2010.pdf (see page 7)

That being said, I can’t find any pre-made 8-pin to 8-pin male PCI-E cables. It would seem like this seller had some at some point but raised their price to a ridiculous amount rather than removing the listing: http://www.ebay.com/itm/380488749075

You could always make your own cable – you can purchase the connectors and terminals from digikey or mouser and get the right gaugue wire and crimp them yourself, but that gets into being a pain.

Ideally, you’d want to connect both. I’m not sure if you have any free molex or sata power connectors in that server, but if you do, you could get adapters like this to populate the 6-pin PCI-E connector on the C2070:

http://www.newegg.com/Product/Product.aspx?Item=9SIA2V51P18403 http://www.newegg.com/Product/Product.aspx?Item=N82E16812400106

For that matter, similar adapters to the ones listed above exist with an 8-pin connector. That being said, not sure if that would be a wise recommendation… depends if the power supply would be able to push that much power over the SATA/molex connectors.

Edit 1: Aha! Here is what you are after ;)
http://www.ebay.com/itm/331265030853

Edit 2: Actually that’s an 8-pin to a 6-pin cable, now I understand what you’re saying… you mean that this is the cable you have currently, correct? If so, you need something like this: http://www.newegg.com/Product/Product.aspx?Item=9SIA30R1SX5209
or even better:
http://www.frozencpu.com/products/8251/

So… basically… if you do not have the VGA1 Dell P/N 0MG89 cable I listed next to ‘Edit 1’, get that, and the last link above (the splitter cable from frozencpu)

The C2070 will be properly powered either with the 8-pin socket mated to an 8-pin cable, or the 8-pin socket mated to a 6-pin cable and the 6-pin socket mated to a 6-pin cable. If you can find a splitter cable for your PSU that goes from 8-pin to dual 6-pin, that should work.

So I’ve got the new power supply and 8-pin cable installed. The LED’s on both sockets on the Tesla are green now. Before the empty one was red when I was trying the single 6-pin connector.

However I am getting the same unknown error from nvidia-smi -a : “Failed to initialize NVML: Unknown error”

I did a clean install of the drivers and made sure all my existing AMD graphics drivers were uninstalled.

This is what I ended up finding/using btw:

http://www.amazon.com/Silverstone-Tek-Sleeved-PCI-E-PP06B-2PCIE70/dp/B00A45JA4S/ref=sr_1_41?s=pc&ie=UTF8&qid=1407355400&sr=1-41&keywords=8-pin+pci-e

it’s an 8-pin to dual 6+2 PCI-e cable. So I can either fill just the 8-pin socket on the Tesla, or both. So far with just the 8-pin filled I am still getting all the original errors.

Also: I am not sure if this is related, but I can’t get NVIDIA control panel to come up. When I try and open it through windows control panel it shows up in the task manager, but no window shows up.