Tesla t4 on hpe gen 10 not active

hello everyone, I have installed in a remote Data center an HPE ProLiant DL380 Gen10 with Windows Server 2016 64 Bit, to that we have inserted an Tesla T4. the problem is that when i connect remotely i dont see the GPU working. More precisely the GPU shows in device manager but when i run the 3d modeling tool the GPU appears as “Inactive”, also the GPU does not appear to run the task manager. I tried to select the Tesla GPU as preferred one from the NVidia Control Panel setting but i dont have the 3d setting options. can someone help to solve this as the whole purpose on the server was to use the GPU and we can’t use that. thank you


did you check the following:
Steps are as below:

  • Open the Edit Group Policy tool from Control Panel or use the Windows Search dialog (Windows Key + R, then type in gpedit.msc)
  • Browse to: Local Computer Policy\Computer Configuration\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Remote Session Environment
  • Then enable “Use the hardware default graphics adapter for all Remote Desktop Services sessions”
  • Update the Group policy

BTW: You won’t see the GPU in task manager with WinServer2016. Just not implemented. Works starting with 2019


thank you, i tried the suggested steps and still not working, i tried again to select it as the prefered one but when opening the nvidia control panel i have the following message even if i can see the gpu in device manager

Which Nvidia (vGPU driver) do you use?
Please stay or use the vGPU 13.x path. NVIDIA Virtual GPU (vGPU) Software Documentatio

Please check the device manager first. Looks like there is no GPU detected at all in your setup.


Hello again,

Let me explain the whole context.
we have installed in a DC an HPE ProLiant DL380 Gen10 with Windows Server 2016 64 Bit, to that we added NVIDIA T4 16GB GPU. We use the servers remotely, so we log in from different location and when we run our 3d tool the server is working only on the integrated GPU, not the NVIDIA and this make the whole process verry slow. On the other hand, we can see the NVIDIA GPU in Device Manager, that means is properly installed (see screen)

I have tried to set the NVIDIA GPU to be the preferred one, both from Bios ( i can’t find the VIDEO Option as in the image), for some reason it is missing)

also, i could not find the 3d setting when right click on NVIDIA Control Pannel.
i have no idea what might be the problem.

Sorry for the late reply.
You need to set the right Windows local policy to use the GPU for RDS sessions:
On Windows Server 20xx, Remote Desktop Services (RDS) sessions on the RD Session Host server use the Microsoft Basic Render Driver as the default adapter. To use the GPU in RDS sessions on Windows Server 20xx, enable the Use the hardware default graphics adapter for all Remote Desktop Services sessions setting in the group policy Local Computer Policy > Computer Configuration > Administrative Templates > Windows Components > Remote Desktop Services > Remote Desktop Session Host > Remote Session Environment

Was a solution ever found for this?
I have an Azure VM with a Tesla T4 but no matter what I do, I cant get applications to use it.
Ive made my changes to group policy. Ive tried manually installing the drivers and using the nvidia extensions in Azure.
The status in Nvidia control panel is perpetually as shown below:
(There are no applications running on this GPU.)


In my case, Ive tried a number of OS. Not sure how to use this T4.