Tesla T4, VMware ESXi 7.0.1 and Citrix Virtual Apps and Desktops not working


I have a strange situation:

Dell R6525
2x Tesla T4
VMware ESXi 7.0.1, 17325551

Two VMs with Server 2019 and Citrix Virtual Apps and Desktops 7 1912 LTSR
Each VM has one Tesla T4 (in direct passthrough)

Nvidia driver 461.09

In windows device manager the Teslas showed up with no error (also the VMware SVGA 3D)

When i run GPU-Z the Tesla showed up correctly with all its data (and 15360 MB memory size, which i think is correct)

When i run dxdiag there are some problems:
Name: unknown
Vendor: unknown
Chip type: unknown
DAC-type: unknown
Device type: not applicable
Memory: 24575 MB (??)
Driver: unknown
Dirver-Version: unknown

If i run some Benchmarks in a Citrix Desktop Session (Unigine Heaven) it runs only with DirectX11 settings and 5 frames per second. CPU-load is at 80%, GPU-load (on GPU-Z or GPU Profiler) is at 0%

So i think the card is not working correctly or i have some misconfiguration.
Or is it because i have not eny license yet because I am in an test phase at the moment?


Without a license, the driver is limited to ~3FPS–which it sounds like you are hitting.

Nope. You need to enable the local policy in Server OS to allow to use the GPU in RDS sessions :)

To use the GPU in RDS sessions on Windows Server 2012, enable the Use the hardware default graphics adapter for all Remote Desktop Services sessions setting in the group policy Local Computer Policy > Computer Configuration > Administrative Templates > Windows Components > Remote Desktop Services > Remote Desktop Session Host > Remote Session Environment.