Tesla T4 Windows 10 1803 could not update drivers from 10.0 (441.66) to any newer versions

i got a big problem updating my virtual Windows 10 clients. Initial i’ve setup an environment with multiple vSphere 6.7 hosts and NVIDIA grid drivers version 10.0. Now i want to update these hosts to a newer version because we have trouble with the graphic performance (black screens and driver crash in the guests). My first try was to update within the major version to 10.2. I put one host in maintenance and install the new host driver VIB. Check with nvidia-smi -> all fine. After them i used one VM to test the guest driver. Driver update failed. I uninstall the old driver, reboot the vm and install the new driver -> installation failed. I run this as administrator and i stopped the virus protection. After them i tried to update to version 11.0. My host is fine but the guest driver installation failed. I checked the same thing with two other VM’s -> same result.
If i deployed a new vm (same OS, drivers and so on) then the driver installation works. But i have around 100 exsisting VM’s - they could have all the same failure. I checked the filesystem with sfc /scannow and used dism to control that Windows isn’t damage. No hidden devices or something else. It’s very frustating.

The installer logs show’s an error:

334 |    ERROR: [NVI2.NVAppPhase] 770@CNVAppPhase::InvokeApp : Executable failed. 
     91.334 |     INFO: [NVI2.NVInstaller] 2930@CNVInstaller::InternalPerformInstallPackagePhases : Exiting Checkpoint: Processing package phase "containerInstall" ( 1406 ms ). 
     91.334 |     INFO: [NVI2.NVInstaller] 1969@CNVInstaller::InternalPerformInstall : Exiting Checkpoint: Processing Package Phases in "Display.Driver" ( 72094 ms ). 
     91.340 |    ERROR: [NVI2.NVInstaller] 1990@CNVInstaller::InternalPerformInstall : Package "Display.Driver" failed with error: Exception {0xe0e00059; File: PerformInstall.cpp; Line: 3955; Phase failure}. 
     91.338 |    ERROR: [CPLUtil] 808@CPLUtil::CPLInstallSuccess : Control Panel install result data key not found. 
     91.339 |    ERROR: [DisplayDriver.DisplayDriverExtSite] 4537@CDisplayDriverExtSite::ConfirmCPLInstall : Uninstalling "Display.Driver" due to the failure of Display.ControlPanel. 
     92.072 |    ERROR: [NVI2.NVInstaller] 2489@CNVInstaller::InternalFinalizePackage : Error Exception {0xe0e00050} while finalizing package. 
     92.072 |    ERROR: [NVI2.NVInstaller] 2049@CNVInstaller::InternalPerformInstall : Failing at package "Display.Driver" failed with error: Exception {0xe0e00059} - aborting install. 
     92.072 |     INFO: [NVI2.NVInstaller] 1845@CNVInstaller::InternalPerformInstall : Exiting Checkpoint: Processing Package "Display.Driver" ( 72844 ms ). 
     92.072 |     INFO: [NVI2.NVInstaller] 1825@CNVInstaller::InternalPerformInstall : Exiting Checkpoint: Processing Packages ( 72844 ms ).

I contacded the nvidia support but with different time zones it’s very long between any answers. Has anyone an idea what i can check?

Let’s start with the basics. How are you updating the driver? Gui? CMDline? If command line what commands are you using to do the install? And on the windows 10 side, what OS release are you using, have you confirmed it’s supported by 10/11?

If the above all looks good I’d try installing just the driver and seeing how it works. Currently I do the below for our driver installs and it seems to work

  1. Extract Driver to folder
  2. Run Cmdline installer to setup.exe
  3. Set installer parameters to -silent -noreboot -clean -noeula -nofinish -passive Display.Driver Display.NVWMI
  4. Reboot when complete

Hi garyd,

thanks for your reply. My goal is to update these drivers through CMDline. But since it failed i tried GUI installer too. My parameters are nearly the same as yours (without -passive and the packages).
My Windows 10 version (ver. 1803) are supported with driver version 10.X and 11.0.

Now i tried your one. Extract the installer, run setup with your parameters and then reboot the vm. After reboot i could not see NVIDIA control panel and the device manager shows only a "Microsoft Basic Display Manager" instead of the NVIDIA Grid Display.

That’s super odd. I’d try to confirm that any Nvidia settings/folders/Registry items haven’t been left on the machine that could be blocking the install.

Would also try installing with just the Display.Driver package to see if that can work. Might make it easier to parse the logs to see if something seems off. I don’t have any a t4 so i can’t help by doing a more thorough test here.
If no luck I’d definitely try to get a support ticket open, there may be a know issue that can fix this.