Test and verify message published via amqp

Hi everyone.

I try to run deepstream-test4-app with amqp. I installed rabbitmq server on my xavier and tried to get the message published.

When I run the test4, ds.log could get the message that published by program. I also followed README of amqp-protocol-adapter, but I can not get messages using amqp-consume.

Could anyone help me with this?

Thanks in advance

• Hardware Platform (Jetson / GPU):Jetson Xavier
• DeepStream Version: 4.0.2
• JetPack Version (valid for Jetson only): 4.3

You can not get messages sent by test4 sample or created from standard input by script of amqp_protocol_adaptor?

Thank you for your reply.

Yeah. I can not get anything via this command
amqp-consume -q "myqueue" -r "topicname" -e "amq.topic" ./test_amqp_recv.sh

Maybe I misunderstood something?

I solved the problem by printing out self->topic in gstnvmsgroker and changed routing_key in

rabbitmqadmin -u guest -p guest -V / declare binding source=amq.topic destination=myqueue routing_key=topicname

to the topic printed out.

Glad to know.