TF >2.0 error

Board: TX2
OS: Ubuntu 18.04
Python: 3.6.9
Jetpack: 4.5.0
L4T: 32.5.2

I installed using the
sudo pip3 install --pre --extra-index-url https://developer.download.nvidia.com/compute/redist/jp/v45 tensorflow==2.4.0+nv21.5. It was successfull.
But as soon as I try to import tensorflow, I Keep getting:
Illegal instruction (core dumped) ERROR.

I made a search and it seems like it is because of an incompatible CPU architecture. TensorFlow is optimized for modern CPUs with support for AVX instructions, which provide significant performance improvements for deep learning workloads. and mine doesn’t support AVX instructions.
Does that mean TF is not available for my board?

P.S.: I need TF >2.0. I tried TF 1.2, it works fine but the many tf methods in my script aren’t supported in TF1.2.

Hi,

It’s more recommended to upgrade your device to JetPack 4.6.x.

The ‘Illegal instruction’ is a known issue from NumPy.
Please check below for more info:
https://elinux.org/Jetson/L4T/TRT_Customized_Example#.22Illegal_instruction_.28core_dumped.29.22

Thanks.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.