TGD 2.0 target 32bit & 64bit library file.


English is not a my native language. Pardon me.

I am using UnityEngine5 in android platform.
I am testing on shield tablet k1.

I am trying to attach my game to TGD 2.0.
First, I have tried as device root method. because, there are a lot documents using root.
I failed.

Anyway, I am trying to attach my game to TGD 2.0.
Run TGD 2.0.
I select my game, then I click “Install Debugger”.
There are some logs about pushing lib files and
“Setting property to LD_PRELOAD=/data/lib/”.
Then, I click “Launch”. but it fails with “No attachable processes found.”

So, I tried link library on java code manually.
When I call loadLibrary(“Nvidia_gfx_debugger”) in java code. it fails.
The error is
“java.lang.UnsatisfiedLinkError: dlopen failed: “…/lib/arm/” is 64-bit instead of 32-bit”

The lib file is copied form “C:\Program Files (x86)\NVIDIA Corporation\Tegra Graphics Debugger 2.0\target\android-kk-egl-t124-a32”

I looked files in “android-L-egl-t132-a64” also.
I found, Both files in each folder are same size( by bytes ).
Is it corret? I’m not sure.

I need some help or any advices.


  1. with root category, does your application launched or not after you press “Launch” button?

  2. with static-link category, can you share your makefile?