TGD not worked but with success

hi, I meet some troubles as below when using TGD, could anyone give some advices, thx!

Find target process. pid:10779
Inject failed, information:
Attaching to thread: 10779… SUCCESS
Attaching to thread: 10784… SUCCESS
Attaching to thread: 10785… SUCCESS
Attaching to thread: 10786… SUCCESS
Attaching to thread: 10787… SUCCESS
Attaching to thread: 10788… SUCCESS
Attaching to thread: 10789… SUCCESS
Attaching to thread: 10790… SUCCESS
Attaching to thread: 10791… SUCCESS
Continued (but attached): 10779
@ Injecting library /data/data/ into process 10779.
@ Calling dlopen in target process …
WARNING: linker: /data/data/ unused DT entry: type 0x1d arg 0x35c9
@ localHandler returned 0xf7350824
@ localInitCall returned 0xf71d64f9
@ remoteInitCall returned 0xef7234f9
@ calling InitializeHookOpenGL with params /data/data/
@ dlopen returned 0x0

host: windows 7
tgd version: 2.4.21613000
target device: nexus 9

Could you please provide more information?

  • Your device android version, OS build number
  • Is your device rooted?
  • Can your app run without launching through TGD?
  • Is your app debuggable?
  • Your detailed steps of reproducing this issue

If possible, can you share your app for us to reproduce this issue?


hi, codym_nv, thx for your reply, more details as below:

  • device android version 6.0, and OS build number3.10.40-g909db78
  • device rooted with adbd insecure
  • app could run rightly without TGD
  • the app is debuggable
  • the seteps:
    a. connect the divece to pc
    b. open the TGD
    c. select the app in tgd “Launch APK” list
    d. click Launck APK
    then the issue produced

and I tried again found that all apps on my nexus couldn’t run with TGD

thx for any of your advice

Sorry for late reply.

How did you root the device?
We have tried on a non-rooted Nexus 9 with android 6.0.1, TGD v2.4 works fine.

By the way, there will be a new version of TGD releasing in the coming weeks, you may want to try it on the new version :)

Is there info on the new TGD version?