The AD/DA HIGH PRECISION BOARD with Jetson Nano does not connect

Hi, I have the following issue.

I bought a High Precision AD/DA and followed the steps in this forum: High-Precision AD/DA Board - Waveshare Wiki. But when I run my script it tells me an “ID READ FAILED” error, I checked all the forums and there is not much information on how to fix it.

I read that I had to activate SPI, and I did, but I still have the same problem. What can be the solution.

These are the configuration pins for my Jetson Nano Developer Kit.

# Pin definition
RST_PIN         = 18
CS_PIN       = 22
DRDY_PIN        = 17

clib = ctypes.cdll.LoadLibrary
spi = clib('./')
# SPI device, bus = 0, device = 0

I followed the steps on this forum GitHub - JetsonHacksNano/SPI-Playground to activate my SPI, but it still doesn’t work.


Welcome to the NVIDIA Developer forums! This category is for forum feedback, Jetson issues belong here: Jetson & Embedded Systems - NVIDIA Developer Forums

I will move this to the Nano category so the Jetson team has visibility.


1 Like

Hi garcia9ag1,

Are you using the Jetson Nano devkit? with SD or eMMC module?
What’s your Jetpack version in use?

You could refer to the following thread to enable and verify SPI loopback first.
Jetson Nano SPI Bus Not Working - #10 by KevinFFF

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.