The application compiled by toolchain can't run in orin board

I have a Orin board with below information.
Model: NVIDIA Orin Nano Developer Kit - Jetpack 5.1.1 [L4T 35.3.1]
NV Power Mode[1]: 7W
Serial Number: [XXX Show with: jetson_release -s XXX]
Hardware:

  • 699-level Part Number: 699-13767-0005-300 K.2
  • P-Number: p3767-0005
  • Module: NVIDIA Jetson Orin Nano (Developer kit)
  • SoC: tegra23x
  • CUDA Arch BIN: 8.7
  • Codename: P3768
    Platform:
  • Machine: aarch64
  • System: Linux
  • Distribution: Ubuntu 20.04 focal
  • Release: 5.10.104-tegra
  • Python: 3.8.10
    jtop:
  • Version: 4.2.3
  • Service: Active
    Libraries:
  • CUDA: 11.4.315
  • cuDNN: 8.6.0.166
  • TensorRT: 5.1.1
  • VPI: 2.2.7
  • Vulkan: 1.3.204
  • OpenCV: 4.5.1 - with CUDA: YES

I used the toolchain https://developer.nvidia.com/downloads/embedded/l4t/r36_release_v2.0/toolchain/aarch64--glibc--stable-2022.08-1.tar.bz2 to comple an application on my Ubuntu PC. Then I copied the application to my orin board and ran it. But I got error as below:
./tvpn_client client.conf
./tvpn_client: /lib/aarch64-linux-gnu/libc.so.6: version GLIBC_2.33' not found (required by ./tvpn_client) ./tvpn_client: /lib/aarch64-linux-gnu/libc.so.6: version GLIBC_2.34’ not found (required by ./tvpn_client)

Is it becaues I used wrong toolchain version?

Hi,

The toolchain is for r36 which is from JetPack 6 and Ubuntu 22.04.
But your environment is JetPack 5 and Ubuntu 20.04 which is not compatible.

Please use the tool in the below link instead:

Thanks.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.