The ar0231 camera does not work properly in 5.0.2

The error is that the avdd-2.8v. is missing and the power supply is not normal

Here’s my configuration for fixed-regulator
Uploading: 微信图片_20220907111132.png…

We look forward to your help

tegra194-fixed-regulator-p2822-1000.dtsi (5.0 KB)
tegra194-camera-ar0231-a00.dtsi (30.8 KB)

hello 1098852226,

are you porting your sensor driver? is this camera driver worked in previous JetPack release, i.e. kernel-4.9?
since JetPack-5.0.2 is now using kernel-5.10. please also refer to developer guide, Camera Driver Porting.

Hello JerryChang thank you for your reply my camera driver originally ran in version 4.9 but I tried to port to 5.0.2 and encountered some problems with the regulator, my driver does not seem to get this voltage of avdd-2.8v

I wanted to understand why I needed avdd-2.8v, which was disabled by the kernel

hello 1098852226,

could you please check kernel driver side, is that vana read correct DT settings in of_property_read_string?

Yes he was right
2022-09-08 15-45-59屏幕截图

hello 1098852226,

I’m wondering why kernel logs indicate the regulator get failed by vana, it looks you actually used avdd.
could you please examine this, please dig into device tree for checking, thanks

Yes I checked that my configuration should come according to the development documentation if you can help me look at it would be appreciated
tegra194-fixed-regulator-p2822-1000.dtsi (5.0 KB)

hello 1098852226,

I see some reference device tree that maps avdd-reg = "vana";
so, please dig into your sensor device tree.

tegra194-p2822-0000-camera-ar0231-a00.dtsi (4.9 KB)
tegra194-camera-ar0231-a00.dtsi (30.8 KB)

Thank you. This question has bothered me for a long time. Can you point out my mistakes

hello 1098852226,

please check you’ve include your AR0231 device tree into this camera device tree sources.
for example, public_soruces/kernel_src/hardware/nvidia/platform/t19x/galen/kernel-dts/common/tegra194-p2822-camera-modules.dtsi
you should add #include "tegra194-p2822-0000-camera-ar0231-a00.dtsi" into this dtsi sources.

Thank you for your help Jerry Chang. Yes, I am sure I have added the device tree of ar0231 in tegra194-p2888-0001-p2822-0000.dts, and configured the relevant fixed regulators in tegra194-fixed-regulator-p2822-1000.dtsi, but their status is displayed as disabled in the kernel print information.

no, please have a try for having this dtsi file included, tegra194-p2822-camera-modules.dtsi, and adding your AR0231 dtsi there.

Thanks for your reply I have now followed the instructions I have already done, but with a new problem encountered, I did not find that there was a videos node

The following are the startup logs:
[ 10.258836] ar0231 2-0061: probing v4l2 sensor.
[ 10.269049] ar0231 2-0061: tegracam sensor driver:ar0231_v2.0.6
[ 10.274298] ar0231 2-0061: Detected AR0231 sensor
[ 10.279392] ar0231 2-0062: probing v4l2 sensor.
[ 10.283875] debugfs: Directory ‘ar0231_a’ with parent ‘/’ already present!
[ 10.290348] ar0231 2-0062: tegracam sensor driver:ar0231_v2.0.6
[ 10.296018] ar0231 2-0062: Detected AR0231 sensor
[ 10.301662] ar0231 2-0063: probing v4l2 sensor.
[ 10.305748] debugfs: Directory ‘ar0231_a’ with parent ‘/’ already present!
[ 10.312689] ar0231 2-0063: tegracam sensor driver:ar0231_v2.0.6
[ 10.318612] ar0231 2-0063: Detected AR0231 sensor
[ 10.323827] ar0231 2-0064: probing v4l2 sensor.
[ 10.328106] debugfs: Directory ‘ar0231_a’ with parent ‘/’ already present!
[ 10.334789] ar0231 2-0064: tegracam sensor driver:ar0231_v2.0.6
[ 10.340809] ar0231 2-0064: Detected AR0231 sensor
[ 10.345832] ar0231 2-0065: probing v4l2 sensor.
[ 10.350512] ar0231 2-0065: tegracam sensor driver:ar0231_v2.0.6
[ 10.355947] ar0231 2-0065: Detected AR0231 sensor
[ 10.361334] ar0231 2-0066: probing v4l2 sensor.
[ 10.365363] debugfs: Directory ‘ar0231_e’ with parent ‘/’ already present!
[ 10.372117] ar0231 2-0066: tegracam sensor driver:ar0231_v2.0.6
[ 10.377984] ar0231 2-0066: Detected AR0231 sensor
[ 10.383014] ar0231 2-0067: probing v4l2 sensor.
[ 10.387392] debugfs: Directory ‘ar0231_e’ with parent ‘/’ already present!
[ 10.394016] ar0231 2-0067: tegracam sensor driver:ar0231_v2.0.6
[ 10.400388] tegra-camrtc-capture-vi tegra-capture-vi: subdev ar0231 2-0067 bound
[ 10.407378] ar0231 2-0067: Detected AR0231 sensor
[ 10.412696] ar0231 2-0068: probing v4l2 sensor.
[ 10.417047] debugfs: Directory ‘ar0231_e’ with parent ‘/’ already present!
[ 10.423622] ar0231 2-0068: tegracam sensor driver:ar0231_v2.0.6
[ 10.429751] tegra-camrtc-capture-vi tegra-capture-vi: subdev ar0231 2-0068 bound
[ 10.437091] ar0231 2-0068: Detected AR0231 sensor


hello 1098852226,

it looks linux kernel has detected AR0231 sensor, but there’s failure related to debugfs
please review your code and try to resolve it, even though I don’t think this error cause registration failed.
you may also dig into kernel logs, please looking for tegra194-vi5 for more clues…

Can you elaborate on what this tegra194-vi5 is?

hello 1098852226,

it looks endpoint is not enabled. please check your port bindings. you should toggle the status as okay.