The audio ALC5640 can't work on I2S0 and I2C2 for Xaiver NX

20210617-arecord.log (67.6 KB)
20210617-boot.log (67.2 KB)
20210617-csetamixer.log (67.4 KB)

Hi mkumard,
20210617-boot.log after reboot
20210617-csetamixer.log after cset
20210617-arecord.log after arecord.log

Hi lcc0610,
From the log, seems like one more change was missing from dts file. The codec sysclk was not set to right clock rate. Can you please add the below change in the dts file. The below change configure codec sysclk as 256*fs. If you want to change to any specific value please do as per your need.

		nvidia,xbar = <&tegra_axbar>;

+		mclk-fs = <256>;

		nvidia,dai-link-1 {
			name-prefix = "y";
		};

The above change might avoid the errors seen on the dmesg log.

20210618.log (62.2 KB)
Hi mkumard,
After add “mclk-fs = <256>;” in the dts file, there is no error message in the upload dmesg, but still no voice for recorded data. Please advice the microphone function. Thank you!

Hi lcc0610,
Can you please try with the below list of commands. If you still face the issue, We would recommend you to contact realtek team to get exact information on the controls needed for capture.

amixer -c 1 cset name="x ADC Capture Switch" "1"
amixer -c 1 cset name="x ADC IF1 Data Switch" "1"
amixer -c 1 cset name="x RECMIXL BST1 Switch" "1"
amixer -c 1 cset name="x RECMIXR BST1 Switch" "1"
amixer -c 1 cset name="x Stereo ADC MIXL ADC1 Switch" "1"
amixer -c 1 cset name="x Stereo ADC MIXR ADC1 Switch" "1"

Hi mkumard,
I tried these commands but microphone still not work. Even we check the waveform is also no any data from the microphone. Any other directions? Or what should we contact with realtek for clarify? Thank you!

Hi lcc0610,
It would be better to contact realtek team to check if any change is missing on dtsi or mixer control side to verify capture data. What we suggested was from the mixer control log you have provided. So we are limited here to provide more suggestions.


Hi
After add mic and micbias configurations into DTS as shown in picture. The microphone function is worked. We checked the record data can replay voice normally. Update the result for sync to you. Thank you!

Hi lcc0610,
This is great news to hear. Thanks for updating the fix, this could help for future references.

I believe we can close this thread now as fixes were working.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.