The board has a short circuit

I tried to get going with my new Jetson Nano Dev Board but there seems to be a major hardware issue.
When I connect the µUSB there is no reaction at all. No LEDs, no nothing …

So I took my multimeter and did some tests and it seems that there ist a short between 5V an GND. This is meassured at the GPIO Pin Header, but also on other location on the board. If I remove the Nano module from the dev board the short goes away, so I guess there is something wrong with the Nano module itself.

Any ideas what the problem could be?

Can you measure the resistance between 5V and ground on the module? The 5V power pins are first ones on the left side.
See this pic for reference: https://imgur.com/a/twOiogb?

I measured 18.8 KOhm.

Nano modul:
Imgur

Ok, I might have made a mistake and measured between 5V an REF instead of 5V and GND Pins. But still the board is doing nothing.
No Power LED or any other reaction …

Make sure J48 is open if you are trying to power the Nano DevKit with the MicroUSB jack. The following is a direct quote from the official User Guide.

[J48] Enables either J28 Micro-USB connector or J25 power jack as power source for the developer kit. Without a jumper, the developer kit can be powered by J28 MicroUSB connector. With a jumper, no power is drawn from J28, and the developer kit can be powered via J25 power jack.”

Yeah, I know. Sadly that is not the problem, because this would be easy to fix. It makes no difference if there is a jumper on J48 or not, in my case.

heiss,
Sure acted a lot like the board I had a problem with. I did see opportunities for short circuits on the carrier board due to insufficient spacing between traces. A couple of quick things.

  1. There is a chance that the power supply is collapsing under load – circuitry detects a high instantaneous load at boot and shuts down to protect the circuitry downstream. With the nano module removed, the high-current draw device is gone, and the power supply stays active.
    a) Try a different power supply – perhaps through the DC barrel jack. (2.54 mm jumper on J48 to use barrel jack)
    b) Disable auto-power on by placing a 2.54mm jumper between J40.7 and J40.8. Hook up an oscilloscope to the 5V power rail, trigger on negative going slope, at around 4.75 Volts or so. Then short J40.1 and J40.2 with a paperclip or tweezers. The green led should turn on, and the power rail is supposed to stay at 5.0 V.
    c) If there is a short – the path the current takes will generate a lot of heat – Do any components look “burned”? Do you have access to a FLIR camera (e.g. FLIR one)? Do any parts of either board feel hot to the touch? Does the board smell burned? Did you see a puff of “magic smoke” on first boot up?
  2. Do you have access to a microscope? You might be able to visually identify a short if it exists on one of the outer layers.

I recommend and support https://pinout.xyz for excellent GPIO pages. This is for the RPi and there will be minor exceptions.

Hi heiss,

Not sure if problem resolved, or maybe other cause on the problem board, you could go through RMA:
https://developer.nvidia.com/embedded/faq#rma-process

My Jetson Nano carrier board have a short circuit between 5v,3v and gnd . Can anyone help me which ICs or other components are malfunctioning.
When I power the board there is no reaction. I’ve tried powering it with GPIO,µUSB and barrel jack but still no response.
Plz reply as soon as possible.

Hi youshanasood,

Please help to open a new topic for your issue. Thanks