The convex decomposition of object is larger than the object itself

Hi,
I select “convex decomposition” when importing a urdf. When checking the colliders, I found the convex hull is much larger than the object itself.

How to make the convex hull be as close as possible to the object?

Can you show a screen shot of your Stage tree? I wonder if that collision mesh is not actually built on the visible mesh, but on some other, hidden mesh.


I increased the value of property->physics->Advanced->Voxel Resolution(default value: 50000), it seems the convex hull is much tighter. I’m not sure whether this is the right parameter.

But the Voxel Resolution is not shown by default. It will show after I change Approximation from “convex decomposition” to another and back to “convex decomposition” again.