the flashed os has no sudo, vi command

the flashed os has no sudo, vi command, i can,t adapter the ip address of the tx1 board

Those commands should be available. Not having those commands would suggest there may be problems with permissions, e.g., sudo is required on the host side during flash at some stages, but lacking sudo on host side will not give a flash error…the error would only show up later on the booted Jetson.

Note: Some file types require root authority (given by sudo) to be created or moved. Many files must have root ownership, and during flash creation of the loopback mountable image cannot be correct unless root is used (because only root can create root ownership).

Was flash from JetPack, or from “flash.sh” command? If flash.sh, be sure unpack of sample rootfs file system is via sudo, and that the “flash.sh” program is run sudo.

what do you mean by “the flashed os”?

The OS on the carrier board eMMC most certainly has them. Unless you got a used or otherwise not pristine board, and the previous owner has messed it up, in which case you can always recover by following the recover-from-usb instructions.

If this is something you put on an sdcard or on an attached drive, you can always mount it on another machine and make an suid shell to get you started, and you can proceed from there.

I 'm just use the JetPack-L4T-2.1-linux-x64.run tools to install the develop environment, but after flashed the os, i login the TX1 board, and type down the sudo command to adjust the ip address of my board, but the bash notify me like this, can’t find the sudo command.May be, I should use the old version JetPack-L4T-2.0-linux-x64.run

Hi,

Did you run the JetPack from your home folder ?

All JetPack versions have those commands…something went wrong with the flash, e.g., file permissions or truncation because of insufficient disk on the host. FYI, “df -H” will give disk space summaries.

i make a sub fold cudax1-install in my home folder,then run the JetPack-L4T-2.1-linux-x64.run in that folder. Following the instruction step by step of L4T_Jetson_X1_Developer_Kit_Release_23.2.pdf.

now, i direct use the flash.sh to flash a root file system which named Tegra_Linux_Sample-Root-Filesystem_R23.1.1_armhf, then run the apply_binaries.sh, looks like copy some .so files belong to opengl to target file system, oh, thanks to god, every thing goes in right but not fluent way.

The most recent L4T version is R23.2. See:
https://developer.nvidia.com/embedded/linux-tegra

This should also be the same version installed if you use the package tool JetPack 2.1 on a JTX1.

thank you very much, linuxdev

Hey guys, I’m experiencing a similar problem. Running JetPack-L4T-2.1-linux-x64.run from Ubuntu 14.04 host to Jetson TX1 client. Launched executable with sudo. Selected custom install and selected all the options. Flashes successfully but when the TX1 reboots, it’s this very basic linux command line environment that doesn’t have a lot of basic commands available. /etc/network/interfaces is blank and I can’t edit it to connect to anything because I can’t sudo and the password “ubuntu” doesn’t work for root. Console output from the install at the link below. Any ideas?

http://pastebin.com/00AhBSqK

Do not launch JetPack with sudo.

I tried launching without sudo first, same problem.

+jetsonguy_13 You’ll probably have to clear out the install files that were created from the first time.

If the correct way to launch is without sudo, and that’s what I tried the first time, why would the files created the first time have been a problem?

Here’s what you do. Redownload the 25MB Jetpack file to a different directory and retry the install. Don’t launch with sudo, it should ask you for your password after you start it.