The flashing process stopped at 99%. Jetson TX2

Hello everyone. I am trying to upgrade JetPack 4.2 to 4.4. The problem is that the flashing process stops at 99%. I tried to flash other versions of JetPack, change the wire and the host machine, but it all came down to the same problem. I attach the sdkmanager log and the output of the serial port.Seria_log.txt (339 Bytes) (83.4 KB)

Can you directly try jetpack4.6.1 and with command?

sudo ./ jetson-tx2-devkit mmcblk0p1

Also, are you sure this is not a TX2-4GB or TX2i?

I have the Jetson TX2 developer kit. I tried to execute your command, but that was the end of it:
out_flash.txt (27.4 KB)

Can you check if this module is D02 one? The sticker on it shall have this info.

Hi, WayneWWW,
the mentioned part number is 699-83310-1000-D00 F
Please check the attached image:

This looks like hardware issue to emmc. Do you have other D00 module that can take flash?

Just want to make sure the software side has no problem.

Yes, I have an extra module. But I want to clarify: to do this, I will need to remove the current D00 module and install a new one? Do you have any guidance for this step?

You mean how to physically remove the module from the carrier board?


Just remove the screw around the module and the fan pin and it shall be easily pulled out from the slot.

So, I managed to flash a new processor module for TX2 using JetPack 4.6. But what can I do with the old module? Perhaps there is some way to reset to factory settings?

It is not software problem so there is nothing to reset… please directly RMA the old module.