The fortran editor in not working in Nsight

Hi,
I just tried Nsight and found it interesting but when I downloaded the Photran plugin, I cannot get the fortran Editor to work ( i cannot do any fortran tutorials). Everything else Fortran related is working.
Is this a bug or can I make it work.

Ubuntu 10.04

Thanks

We have not tested Fortran plug-in in Nsight and Nsight does not introduce any special support for Fortran.

Please provide more details on failures you are observing. Thank you!

Thank from for your prompt answer.

This is after having imported a fortran file into a project and double clicking on the file name

From the popup

An error has occurred. See error log for more details.
org.eclipse.jface.text.source.DefaultCharacterPairMatcher.([CLjava/lang/String;Z)V




inside log file

java.lang.NoSuchMethodError: org.eclipse.jface.text.source.DefaultCharacterPairMatcher.([CLjava/lang/String;Z)V

I did check the installation and this file is there.

Apparently, the Fortran plugin you are using is built for a newer Eclipse platform version then the one Nsight 5.0 is based on and does not properly check the prerequisites.

Are you using Photran (part of Eclipse Parallel Tools Project)? I can open a fortran source file when I install Photran 7.0.5 from http://download.eclipse.org/releases/indigo/ repository.

Update: I was also able to build a Fortran project with gfortran and debug the resulting executable in cuda-gdb. Note that this is still not a scenario that went through the NVIDIA QA and it is not considered to be officially supported.

Thank you very much. Did not think about that. I will try that version.

I downloaded the PTP indigo plugin and was able to run a mpi fortran/cuda project. To pass an input file argument, I had to write “-input filename” in the argument field. Then everything works perfectly.

Good to know. Thank you!