the image from TX1 onboard vision sensor is upside down?

I run caffe sample in Tegra_Multimedia_API.
but the image from TX1 onboard vision sensor is upside down.

how to flip the image from TX1 onboard vision sensor by the libargus not opencv?

Hi h145546,
For Tegra Multimedia API, you need to integrate 07_video_convert after Argus to use flip method: 180 degree rotation(-fm 2).

Here is a gstreamer command for your reference:
gst-launch-1.0 nvcamerasrc ! nvvidconv flip-method=2 ! ‘video/x-raw(memory:NVMM),format=NV12’ ! nvoverlaysink

Im having the same issue on my TX2

I update to JetPack 3.1 and when I run the ./imagenet-camera program the image comes in flipped.

does the fix above also work for this or is there something else?


Hi, please try changing the flip-method setting from line 313 of gstCamera.cpp from the repo and recompile.


On line 313 I changed flip-method from (2) to (0) and that worked.

Thank you!

The line 313 change + re-build worked for me as well.


I changed the 313 line, I tried to compile it using the command g++ but i got an error.
How can I recompile the software?
Thank you

If you go to your build directory and just type make, what is the error message ?

Or do you have another error message when running the new build ? Be sure to cd to build/aarch64/bin and run from there.

The thing is, the program runs well, but I would like to use it with the camera on its correct rotation

If I go to my build directory and type build I got an error “No target specified and no makefile found”
Thank you for your help

Now it is solved, thank you for your help