The _imagingft C module is not installed

Hi!

I managed to install Luminoth (https://luminoth.readthedocs.io/en/latest/), respectively compile it using Python3 on Jetson AGX Xavier.

However, when I try to run it (using the

lumi checkpoint list

command), I get the following error:

ImportError: The _imagingft C module is not installed

which seems to be an error having to do with libfreetype6. The compiler somehow cannot find the library files.

Running

ln -sf /usr/lib/aarch64-linux-gnu/libfreetype.so.6 /usr/lib/

as sudo did not help.

Does anybody have a clue what is going on here?

Any help highly appreciated!

Lorenz

Update:

I just tried to recompile Pillow with

libfreetype

using

sudo pip3 install pillow --global-option="build_ext" --global-option="--enable-freetype" --global-option="--debug"

after cloning it from git.

However, this fails with the error

Couldn't find library freetype in ['/tmp/pip-install-z04i1y9l/pillow', '/usr/lib', '/usr/lib/aarch64-linux-gnu', '/lib/aarch64-linux-gnu', '/usr/lib/aarch64-linux-gnu/tegra', '/opt/nvidia/deepstream/deepstream-4.0/lib', '/usr/local/cuda-10.0/targets/aarch64-linux/lib', '/usr/local/lib', '/usr/lib/aarch64-linux-gnu/libfakeroot', '/usr/lib/aarch64-linux-gnu/tegra-egl', '/lib']

although I linked

libfreetype.so

and

libfreetype.so.6

to (some of) these directories. Reinstalling libfreetype via apt is no option, as it cannot locate the package dependencies.

Question is now, which of the files from the standard Jetson-libfreetype install directory (wherever it is…) do I need to link to

/usr/lib

?

Lorenz

Hi,

Would you mind to try libfreetype6-dev?

$ sudo apt-get install libfreetype6-dev

Thanks.

This command unfortunately yields

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libfreetype6-dev : Depends: libpng-dev but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

EDIT: Of course, I did

apt-get update

and

apt-get upgrade

as sudo before!

Hi,

libfreetype6-dev : Depends: libpng-dev but it is not going to be installed

The error is related to libpng-dev. Have you tried to install libpng-dev first?

sudo apt-get install libpng-dev

May I know how do you set up your Xavier?
Both libpng-dev and libfreetype6-dev can be well installed in my environment.

Thanks.