The issue about oem-config


  1. Refer to " Headless Mode Flow in oem-config" of L4T guide, we can use a serial application to run oem-config.
  2. After flashing jetson device then starting up, we can find the output of “Please complete system configuration setup on the serial port provided by Jetson’s USB device mode connection. e.g. /dev/ttyACMx where x can 0, 1, 2 etc.”. And I connected jetson device to host computer with micro usb, found /dev/ttyACM0 on PC, but using putty or screen to open ttyACM0 fail.
  3. I know we can run oem-config by HDMI display, but i want to use a serial method, because i have no more HDMI display.
  4. I have also tried to use a 40‑pin header UART port to run oem-config, it fail too.
  5. My jetson device is Nano, and L4T version is 32.6.1.

What’s the issue about oem-config on serial method?

oem config by default just needs the micro usb port. You don’t need UART.

If you can see the node ttyACM0 but fails to open it, then please reboot the device and console for several times and it shall work.

Thanks WayneWWW!
I have tried reboot and re-plugin several times on micro USB port, but no one success. It seems simple but just not work.
So i have confused the issue what should i do.

If you cannot run pass it, and you are using sdkmanager to flash board, there would be a script under your Linux_for_Tegra folder. You can use that to bypass the oem-config.

OK, thanks !

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.