The nano does not turn on today

Hi, I was playing with my nano last month and everything was fine. But then, today, when I try to turn on the nano, the green LED is on, but blank screen in the LCD. The USB has no voltage.

I put the SD card, and LCD to my new nano and it works fine.

I have tried the J48+ 5V/4A power, same result…
I’m sure the SD card is properly inserted. The SD card slot, HDMI and USB plugs are clean.
I was very careful with the hardware and static charge. And I am sure I didn’t burn any I/O.
Is there anything I can try? May I know if my original nano is broken?


Hi, I did search in the forum… And there is nothing to show as it is a blank screen. (No signal)
Nvidia Nano b01, for the SD card, it is frameware 4.5
One thing I can think of is that my Arduino has an external 5V supply which feed the power back to Nvidia USB port. (Don’t know how to block the power…)
One phenomenon is that the Nvidia Nano can not turn on if my arduino is on by my external 5V supply. I need to unplug the external 5V power so that the Nvidia nano can turn on.
Will this burn the power circuit in the Nvidia Nano development board? (I am sure it is 5V)
Note: For the test in my previous message, I have unplugged my arduino USB to eliminate the uncertainty.


Please check if you can dump the log or flash the board with sdkmaanger.

For serial console log dumps see:


Here is the print out from the serial console:
fw▒▒MBh24:▒▒Ř▒!}▒▒#Hx='▒l,▒▒▒▒k▒;▒t▒▒V▒[0000.125] [L4T TegraBoot] (version 00.00 .2018.01-l4t-e82258de)
[0000.130] Processing in cold boot mode Bootloader 2
[0000.135] A02 Bootrom Patch rev = 1023
[0000.138] Power-up reason: pmc por
[0000.141] No Battery Present
[0000.144] pmic max77620 reset reason
[0000.147] pmic max77620 NVERC : 0x40
[0000.151] RamCode = 0
[0000.153] Platform has DDR4 type RAM
[0000.156] max77620 disabling SD1 Remote Sense
[0000.161] Setting DDR voltage to 1125mv
[0000.165] Serial Number of Pmic Max77663: 0x12ce5
[0000.172] Entering ramdump check
[0000.175] Get RamDumpCarveOut = 0x0
[0000.178] RamDumpCarveOut=0x0, RamDumperFlag=0xe59ff3f8
[0000.184] Last reboot was clean, booting normally!
[0000.188] Sdram initialization is successful
[0000.192] SecureOs Carveout Base=0x00000000ff800000 Size=0x00800000
[0000.198] Lp0 Carveout Base=0x00000000ff780000 Size=0x00001000
[0000.204] BpmpFw Carveout Base=0x00000000ff700000 Size=0x00080000
[0000.210] GSC1 Carveout Base=0x00000000ff600000 Size=0x00100000
[0000.216] GSC2 Carveout Base=0x00000000ff500000 Size=0x00100000
[0000.222] GSC4 Carveout Base=0x00000000ff400000 Size=0x00100000
[0000.228] GSC5 Carveout Base=0x00000000ff300000 Size=0x00100000
[0000.233] GSC3 Carveout Base=0x000000017f300000 Size=0x00d00000
[0000.250] RamDump Carveout Base=0x00000000ff280000 Size=0x00080000
[0000.256] Platform-DebugCarveout: 0
[0000.259] Nck Carveout Base=0x00000000ff080000 Size=0x00200000
[0000.265] Non secure mode, and RB not enabled.
[0000.269] BoardID = 3448, SKU = 0x0
[0000.272] QSPI-ONLY: SkipQspiOnlyFlag = 0
[0000.276] Nano-SD: checking PT table on QSPI …
[0000.280] Read PT from (2:0)
[0000.296] Using BFS PT to query partitions
[0000.301] Loading Tboot-CPU binary
[0000.330] Verifying TBC in OdmNonSecureSBK mode
[0000.340] Bootloader load address is 0xa0000000, entry address is 0xa0000258
[0000.347] Bootloader downloaded successfully.
[0000.351] Downloaded Tboot-CPU binary to 0xa0000258
[0000.356] MAX77620_GPIO5 configured
[0000.359] CPU power rail is up
[0000.362] CPU clock enabled
[0000.366] Performing RAM repair
[0000.369] Updating A64 Warmreset Address to 0xa00002e9
[0000.374] BoardID = 3448, SKU = 0x0
[0000.377] QSPI-ONLY: SkipQspiOnlyFlag = 0
[0000.381] Nano-SD: checking PT table on QSPI …
[0000.385] Loading NvTbootBootloaderDTB
[0000.452] Verifying NvTbootBootloaderDTB in OdmNonSecureSBK mode
[0000.525] Bootloader DTB Load Address: 0x83000000
[0000.530] BoardID = 3448, SKU = 0x0
[0000.533] QSPI-ONLY: SkipQspiOnlyFlag = 0
[0000.537] Nano-SD: checking PT table on QSPI …
[0000.541] Loading NvTbootKernelDTB
[0000.607] Verifying NvTbootKernelDTB in OdmNonSecureSBK mode
[0000.631] NvTbootKernelDTB is corrupted!
[0000.635] Error in NvTbootLoadBinary: 0x14 !
[0000.639] Error is 14

I google this “Error in NvTbootLoadBinary: 0x14 !” and nothing about the nano, only in TX1…!&oq=Error+in+NvTbootLoadBinary%3A+0x14+!&aqs=chrome..69i57.1469j0j7&sourceid=chrome&ie=UTF-8


Then please find a x64 ubuntu 18.04 host and run sdkmanager to flash your board.

Honestly, this error log is rare as your said.

But if I put the SD card in another nano board, it runs. It seems like the hardware problem. :<


We have some software running on the module even when there is no sdcard… It is likely that I say this comment to jetson nano users everyday.

Thus, I don’t suspect your sdcard is fine or not because the problem is not on sdcard at all…

That is why only sdkmanager can save your board.

Thanks, I don’t know how to “flash the board”, may I have the procedure or link of how to do it?

You need to find a x64 ubuntu 18.04 host first. 20.04 or some ubuntu from jetson nano are not allowed. I mean don’t try to use jetson nano to flash another jetson nano.

Refer to the quick start guide to know how to put jetson nano into recovery mode. Recovery mode is required to make the board in a state that can get flashed.

1 Like

Thx. After went through the SDK Manager, the nano is running again.

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.