The NVIDIA driver ignores the descriptions for the monitor and device

I’m confused. I’m running Fedora 33 and I have these two configuration files:

First: /etc/X11/xorg.conf.d/98-screen.conf

Section "Screen"
    Identifier     "Screen0"
    Device         "Videocard0"
    Monitor        "Monitor0"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "My cool monitor vendor"
    ModelName      "Very cool monitor"
EndSection

and /etc/X11/xorg.conf.d/99-nvidia.conf

Section "Device"
    Identifier  "Videocard0"
    BusID       "PCI:7:0:0"
    Driver      "nvidia"
    VendorName  "NVIDIA"
    BoardName   "NVIDIA Corporation TU116 [GeForce GTX 1660 Ti] (rev a1)"
    Option      "Coolbits" "28"
    Option      "metamodes" "nvidia-auto-select +0+0 {ForceCompositionPipeline=On, ForceFullCompositionPipeline=On}"
    Option      "UseNvKmsCompositionPipeline" "Off"
EndSection

When I’m running nvidia-settings however it does not show “My cool monitor vendor”, “Very cool monitor”, or “NVIDIA Corporation TU116 [GeForce GTX 1660 Ti] (rev a1)”.

What it shows is a monitor name fetched from EDID (it’s very generic), and it shows my GPU as “NVIDIA GeForce GTX 1660 Ti (GPU 0)”.

Also, in nvidia-settings's X Screen Display Configuration I see:
Selection:

  • EDID monitor name (selected) and
  • X screen 0 (the first unselected option) which, when I choose it, only shows and allows to change Color Depth and that’s it.

How can I force nvidia-settings to actually use the descriptions I’ve provided for my monitor and device?

From /var/log/Xorg.0.log

[ 14520.374] (==) Using config directory: "/etc/X11/xorg.conf.d"
[ 14520.374] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[ 14520.374] (==) No Layout section.  Using the first Screen section.
[ 14520.374] (**) |-->Screen "Screen0" (0)
[ 14520.374] (**) |   |-->Monitor "Monitor0"
[ 14520.374] (**) |   |-->Device "Videocard0"
[ 14520.374] (==) Automatically adding devices
[ 14520.374] (==) Automatically enabling devices
[ 14520.374] (==) Automatically adding GPU devices
[ 14520.374] (==) Automatically binding GPU devices

@aplattner

Bump!