The onboard camera is not detected on the nvidia jetson TX2

The onboard camera is not detected on the TX. When I entere cd /dev, followed by ls. The directory video0 doesn’t show up. I have also tried enter the following command to test the camera:

gst-launch-1.0 nvcamerasrc ! ‘video/x-raw(memory:NVMM),width=640, height=480, framerate=30/1, format=NV12’ ! nvvidconv flip-method=2 ! nvegltransform ! nveglglessink -e

Setting pipeline to PAUSED …

Using winsys: x11
Socket read error. Camera Daemon stopped functioning…
gst_nvcamera_open() failed ret=0
ERROR: Pipeline doesn’t want to pause.
Got context from element ‘eglglessink0’: gst.egl.EGLDisplay=context, display=(GstEGLDisplay)NULL;
ERROR: from element /GstPipeline:pipeline0/GstNvCameraSrc:nvcamerasrc0: GStreamer error: state change failed and some element failed to post a proper error message with the reason for the failure.
Additional debug info:
gstbasesrc.c(3354): gst_base_src_start (): /GstPipeline:pipeline0/GstNvCameraSrc:nvcamerasrc0:
Failed to start
Setting pipeline to NULL …
#0 0x0000007faa579130 in pthread_join (threadid=548263805440,
#1 0x0000007faa62fed0 in ?? () from /lib/aarch64-linux-gnu/
#2 0x0000000000000011 in ?? ()
Spinning. Please run ‘gdb gst-launch-1.0 3877’ to continue debugging, Ctrl-C to quit, or Ctrl-\ to dump core.

I have update the pip to the most up-to-date. I’m not sure how to solve this issue, I was thinking of install drivers for the camera but I’m not sure which drivers and what website to get the drivers.

Did you working with default camera sensor?
Have a check if any kernel message. dmesg | grep -i ov5693

Hi naanokhin,

Can the default camera work now? Any result can be shared?