The problem of nsight debugging in vs2015, win10.

I followed the tutorial
to try to debug the sample project.
First of all, NSight will ignore all break points in release mode.
Secondly, the NSight will ignore the second break proint (

for (int a = aBegin, b = bBegin;

) in the debug mode.
Thirdly, the NSight monitor will report a warning “CUDA grid launch failed” and “cudaErrorLaunchFailure” in the debugging mode;before the warning, there’s a sudden blackout of the screen.

My graphic card is gtx1080ti and my driver version is 382.33. My OS is windows 10.

I tried to reinstall my OS but the problem is still existed.
I also tried to debug some other sample project such as “cdpSimpleQuickSort”, the error message is a little bit different:
CUDA Dynamic Parallelism debugging is not supported in preemption mode. Breakpoints will be disabled.

The last message is to be expected if the GPU is in WDDM mode, which is always true for GeForce products.

The full message of ouput is as listed. And I think it is in WDDM mode, I ran the deviceQuery in sample and it shows the result of WDDM mode.
CUDA context created : 2bfa3680770
CUDA module loaded: 2bfabd65b40
CUDA grid launch failed: CUcontext: 3022103512944 CUmodule: 3022244961088 Function: _Z13matrixMulCUDAILi32EEvPfS0_S0_ii
CUDA context destroyed : 2bfa3680770

I tried to install the driver to version 382.05 and 381.89, but the same problem is still existed.

Hello. Any news about this problem? I’m having the same problem independently of the kernel code. I’m using VS2015, W10 64Bits, GTX 860M, NSight 5.2 and driver version 382.05

The odd part is that it used to work when I initially installed NSight but from few days ago, I’m having the same error message when trying to debug CUDA.

For my situation, it seems a known issure and the official department is working on solve it. But I have already debugged the other GPU successfullly.