The sampels crashed on ubuntu 22.04

Please provide complete information as applicable to your setup.

• Hardware Platform (Jetson / GPU)
RTX 4090
• DeepStream Version
6.2
• TensorRT Version
8.6.1
• NVIDIA GPU Driver Version (valid for GPU only)
535.129.03
• Issue Type( questions, new requirements, bugs)
bugs

the lib /opt/nvidia/deepstream/deepstream-6.2/lib/libnvds_yml_parser.so need libyaml-cpp.so.0.6 to work, but the ubuntu22.04 use libyaml-cpp.so.0.7 as default.
i installed libyaml-cpp.so.0.6 to compile samples,it works but crashed when running

ldd output:

ldd -r /opt/nvidia/deepstream/deepstream-6.2/lib/libnvds_yml_parser.so
	linux-vdso.so.1 (0x00007ffd6dd45000)
	/lib/$LIB/liblsp.so => /lib/lib/x86_64-linux-gnu/liblsp.so (0x00007fd2eca00000)
	libglib-2.0.so.0 => /lib/x86_64-linux-gnu/libglib-2.0.so.0 (0x00007fd2ec8c6000)
	libgobject-2.0.so.0 => /lib/x86_64-linux-gnu/libgobject-2.0.so.0 (0x00007fd2eccd9000)
	libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007fd2eccd2000)
	libyaml-cpp.so.0.6 => /usr/local/lib/libyaml-cpp.so.0.6 (0x00007fd2ecc56000)
	libstdc++.so.6 => /lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007fd2ec600000)
	libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007fd2ecc36000)
	libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007fd2ec200000)
	libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007fd2ecc31000)
	libpcre.so.3 => /lib/x86_64-linux-gnu/libpcre.so.3 (0x00007fd2ec850000)
	libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007fd2ec519000)
	libffi.so.8 => /lib/x86_64-linux-gnu/libffi.so.8 (0x00007fd2ecc22000)
	/lib64/ld-linux-x86-64.so.2 (0x00007fd2ecdb3000)

make

cd /opt/nvidia/deepstream/deepstream-6.2/sources/apps/sample_apps/deepstream-test1
sudo make

cc -c -o deepstream_test1_app.o -I../../../includes -I /usr/local/cuda-11.8/include -pthread -I/usr/include/gstreamer-1.0 -I/usr/include/x86_64-linux-gnu -I/usr/include/glib-2.0 -I/usr/lib/x86_64-linux-gnu/glib-2.0/include deepstream_test1_app.c
st1_app.c:305:3: warning: ‘gst_element_get_request_pad’ is deprecated: Use 'gst_element_request_pad_simple' instead [-Wdeprecated-declarations]
  305 |   sinkpad = gst_element_get_request_pad (streammux, pad_name_sink);
      |   ^~~~~~~
In file included from /usr/include/gstreamer-1.0/gst/gstbin.h:27,
                 from /usr/include/gstreamer-1.0/gst/gst.h:35,
                 from deepstream_test1_app.c:24:
/usr/include/gstreamer-1.0/gst/gstelement.h:1042:25: note: declared here
 1042 | GstPad*                 gst_element_get_request_pad     (GstElement *element, const gchar *name);
      |                         ^~~~~~~~~~~~~~~~~~~~~~~~~~~
cc -o deepstream-test1-app deepstream_test1_app.o -lgstreamer-1.0 -lgobject-2.0 -lglib-2.0 -L/usr/local/cuda-11.8/lib64/ -lcudart -L/opt/nvidia/deepstream/deepstream-6.2/lib/ -lnvdsgst_meta -lnvds_meta -lnvds_yml_parser -lcuda -Wl,-rpath,/opt/nvidia/deepstream/deepstream-6.2/lib/ 

debug crashed at nvds_parse_gie_type

if (yaml_config) {
RETURN_ON_PARSER_ERROR(nvds_parse_gie_type(&pgie_type, argv[1],
“primary-gie”));
}

Thread 1 "deepstream-test" received signal SIGSEGV, Segmentation fault.
0x00007ffff7a2dc05 in YAML::Node YAML::Node::operator[]<char const*>(char const* const&) () from /opt/nvidia/deepstream/deepstream-6.2/lib/libnvds_yml_parser.so
(gdb) where
#0  0x00007ffff7a2dc05 in YAML::Node YAML::Node::operator[]<char const*>(char const* const&) ()
    at /opt/nvidia/deepstream/deepstream-6.2/lib/libnvds_yml_parser.so
#1  0x00007ffff7a4dc87 in nvds_parse_gie_type ()
    at /opt/nvidia/deepstream/deepstream-6.2/lib/libnvds_yml_parser.so
#2  0x0000555555556c69 in main ()

need help,thanks

Please refer to the dependencies of DeepStream6.2: Quickstart Guide — DeepStream 6.2 Release documentation (nvidia.com)

  • Ubuntu 20.04
  • GStreamer 1.16.3
  • NVIDIA driver 525.85.12
  • CUDA 11.8
  • TensorRT 8.5.2.2

You can use DeepStream6.2 docker if you want to run it in Ubuntu 22.04.

There is no update from you for a period, assuming this is not an issue anymore. Hence we are closing this topic. If need further support, please open a new one. Thanks

As a side note, is libyaml-cpp.so still soft-linked to libyaml-cpp.so.0.7 ?

You can try changing the soft link

ls -l  /usr/lib/x86_64-linux-gnu/libyaml-cpp.so

/usr/lib/x86_64-linux-gnu/libyaml-cpp.so -> libyaml-cpp.so.0.7

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.