Ther are some errors after I RUN the "make tegra21_defconfig" for Jetson TX1.

Ther are some errors after I RUN the “make tegra21_defconfig” for Jetson TX1 3.1.
Who can help I fix the question?
There are the errors is below:


*** Can’t find default configuration “arch/x86/configs/tegra21_defconfig”!


make[1]: *** [tegra21_defconfig] Error 1
make: *** [tegra21_defconfig] Error 2

Which release is this? I am guessing R28.1.

Did you download the source through the source_sync.sh script, or was it from the web page kernel source?

Yes,I use R28.1
I throught the " ./source_sync.sh -k tegra-l4t-r28.1"command to download the source .

I should have probably asked earlier, but is this cross compile on the host, or native compile on the Jetson? I see it is looking for an x86 file, yet the jetson is arm64, so I suspect it is a case of setting up for cross compile. If this was cross compile from a PC host the build commands require additional changes.

FYI, I always save a copy of the default system’s “/proc/config.gz”. This is a better starting configuration than is the defconfig. All you have to do is to be running the kernel before you change the kernel and that file is an in-RAM representation directly from the kernel to tell you exactly how it is configured (well, CONFIG_LOCALVERSION is not set).