There is no device supporting CUDA again and again There is no device supporting CUDA


I have truouble with NVIDIA Tesla C870.

deviceQuery.exe shows me “There is no device supporting CUDA”.

Windows Device Manager shows NVIDIA Tesla C870 and device is working correctly.

I tried my NVIDIA Tesla C870 on different computers,
under Windows XP, Windows XP64, Windows Vista64 with corresponding drivers,
and with SDK 1.1 and with SDK 2.0 beta.

The results are the same.

Please help me.

Which driver did you install?

I tried 169.21 and 174.55 versions.

And that gave the same result.

Do you have an nvcuda.dll on your system?
How are you building the SDK apps?

  1. nvcuda.dll is located in c:\windows\system32 folder.

  2. I’m just trying to run examples in C:\Program Files\NVIDIA Corporation\NVIDIA CUDA SDK\bin\win32\Release.

And all examples show “There is no device supporting CUDA.” message.

Check in the control panel that the HW acceleration for the Tesla card is set to full

Reinstall 174.55 driver and try again. I solved the same problem-“no device” by reinstall the driver. :yes: