"There is no device supporting CUDA" with Radeon x1650

Hi all,

I’m running Windows 7 x64 on a Tyan S7025 motherboard and a Tesla C1060, and an AMD Radeon x1650 graphics card. Unfortunately, every time I install the three CUDA pieces (driver/toolkit/SDK), deviceQuery.exe always comes up with “There is no device supporting CUDA”, and shows me what the CPU emulation mode looks like, instead of finding my Tesla card.

I have tried the 2.2, 2.3 and 3.0 (beta) versions of all three CUDA components.

Does anyone know how to get the CUDA runtime to recognize a Tesla when you don’t have an nVidia graphics card? (I’m assuming that this is the problem, but I could be wrong - any help is welcome!)

Thanks in advance,

Is this with the TCC driver?

I was hesitant to try it as I’m not running server 2k8 - is this the right driver to use for Win7 in this scenario?

Thanks for the reply!


I decided to just go for it, and it worked like a charm! I guess it makes some sense that a cluster-oriented driver wouldn’t worry as much about display drivers - I’m glad nVidia provides a driver for compute devices separately.

Thanks so much for the guidance!


Glad you got it going!