Thermal Sensors inactive with DisplayPort DTB

Hello everyone,

I need your help to understand an issue.
When flashing my TX2i with the DTB that enables Display Port on dp0 instead of HDMI (tegra186-quill-p3489-1000-a00-00-dsi-dp.dtb) 3 thermal sensors are not working anymore :

While when I flash it with base DTB (tegra186-quill-p3489-1000-a00-00-ucm1.dtb) I have all 6 sensors :

When decompiling the DTB to see the differences I see that the thermal sensors zone is 0x37 in dsi-dp.dts while it is 0x33 in ucm1.dts. I tried to change it and recompile but still no change. Maybe something else I didn’t saw ?
Also, in bpmpthermal there is no handle defined. But I can’t modify this point by hand on the decompiled DTB :

Got the same issue with a commercial TX2 and base.dtb / dsi-dp.dtb

Any idea ?

Thank you :)


I am a little confused here and need your answer. Do you create “tegra186-quill-p3489-1000-a00-00-dsi-dp.dtb” by yourself? I don’t see it in my kernel source.

Also, you said “Got the same issue with a commercial TX2 and base.dtb / dsi-dp.dtb”. Did you mean besides TX2i, TX2 also can see such issue?

If so, could you use official dts which enables dsi and dp on TX2 and see if this issue is still?

Hello WayneWWW,

I did not create this DTB, it is already available in L4T 3.3 under 64_TX2/Linux_For_Tegra/kernel/dtb. Also the DTS is available in sources/hardware/nvidia/platform/t18x/quill/kernel-dts/.

Yes I mean that with the TX2 I have the same issue. Base DTB (tegra186-quill-p3310-1000-c03-00-base.dtb) make all sensors working whereas with dsi-dp DTB (tegra186-quill-p3310-1000-c03-00-dsi-dp.dtb) only three are working.



Could you share what is inside your 64_TX2/Linux_For_Tegra/kernel/dtb?

Could you also share how you flash this dtb? In fact, the change between dsi-dp and base device tree only has display related node. There should be no thermal changes.

I can also try to verify it on my side.

Also, I want to make sure that what is the platform that can hit this issue? TX2, TX2i? or both?

Here is a screenshot of both kernel/dtb and sources paths. Sources that are in 64_TX2/Linux_For_Tegra/kernel/dtb directory have been decompiled from the corresponding DTB.

Yes that’s what I also see, in sources it is only a change in display nodes.

./flash -r -k jetson-tx2i mmcblk0p1

with jetson-tx2i symbolic link to p2771-3489-ucm1.conf and its DTB-FILE arg changed from …ucm1.dtb to …dsi-dp.dtb

I hope it is clear …

I have both platforms and they have the same issue.

Yes please tell me if you see the same behaviour in your side

This is weird. I just checked my source and didn’t see any of such “tegra186-quill-p3489-1000-a00-00-dsi-dp.dtb” or dts file.

Could you share the content of this dts?

I am out of TX2 at this moment. will check it tomorrow. Sorry for inconvenience.

Could you also share your full dmesg for us to check?

Ok sorry I was totally wrong … I re-downloaded all the DTB and DTS files. I don’t see those dsi-dp DTB files now, I think I created them months ago to make the Display Port working.

I don’t have p3489 dsi-dp source file (TX2i) but I have p3310 one (TX2).

Let’s take the problem from a TX2 board then, I remember what I have done until now…

I tried to compile “tegra186-quill-p3310-1000-c00-00-dsi-dp.dts” file but I had an error :

ERROR (phandle_references): Reference to non-existent node or label "/bpmp/bpmpthermal"

I found this post that treats the subject and replaced this label by 0x37 ! It compiles but it doesn’t work completely (these 3 out of 6 sensors).

So in other words there is no DTB file for DisplayPort, only one source for TX2 but can’t compile it.

Sorry for the inconvenience, it has been a long time I did that and didn’t remembered.

By the way, the post I linked talks about a “dtc supplied with the kernel” (last reply) because “standard” creates this error. But if it is the one in “64_TX2/Linux_for_Tegra/kernel” it outputs the same error.
But this is another subject, I must reply to the other post or create a new one.

Can you close this post please ?
Thank you for your help !