This app can't be run on your PC

I was going through the instructions for the kit-extension-template - basically calling kit from the command line and suddenly Windows throws the dreaded “This app can’t be run on your PC”. Now I can’t launch Code either. The instructions I was following are located here - GitHub - NVIDIA-Omniverse/kit-extension-template: Omniverse Kit Extension Template.

I tried disabling some windows monitors, I am still getting the notice when I try to launch code or call kit from the console.

Hi @jaalfs. From searching, it sounds like this might be a permissions or registry issue. Have you tried debugging down that path?

I will try that today. It was working until I started calling kit.exe from the console command line. Leads me to believe I tripped some kind of windows security.

Thanks and I’ll update with my results.

I fixed it by uninstalling Kit and Code from the Launcher, then reinstalling both apps.

Great! Glad that worked out.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.