Three Jetson Nano 2GB not responding but SD Card boots correctly in another Jetson device


I ordered 6 Jetson Nano 2GB and set them up.
All of them have the same setup : Alim 5.1V 3A, 7’’ touch screen, ethernet, 32GB SD card flashed with Jetpack 4.5. (I had tried this setup with another Jetson nano before and there was no issue)

Three are working fine. Three don’t boot at all.
The green power light is on, but there is no LED for the Ethernet (cable connected) and no HDMI signal.

I tried to connect the not responding Jetson Nanos on multiple monitors (touch screen and external alimentation), changing cables: Still no signal.
I swapped the SD cards from one ‘not working’ jetson to one ‘working’ jetson nano and the SD cards boots just fine.
If I try to connect the Jetson Nano to a monitor without SD card inserted I only get “no signal”, instead of the nvidia screen with “no sd card”.

Since the SD card is confirmed to be working just fine, I suspect an Hardware issue. However it seems really weird to get 3 defective Jetson Nano in a row…

Is there something I could have done wrong/missed? Or should I just go for a RMA?

Thanks for your help.

If you want to go through a thorough debug process, you can dump the log with below method.

And if you don’t have cable to dump the log, what you can do is find a x64 ubuntu18.04 host and use that to flash these 3 jetson nano with sdkmanager.

Sdkm updates the software on the QSPI-NOR flash on your nano module. However, sdcard image won’t. Which means keep replacing sdcard image won’t resolve the error happened on QSPI-NOR.