Three monitors with one GeForce GT720 (and Ubuntu 15.04, nvidia drivers 346.59)

Hi Folks,

[EDIT: Working now. Not sure what fixed it]

I bought this graphics card for three monitors as a single desktop. (EVGA manufactured, GEForce GT720). I don’t play much games, and those I do play can work fine on a single monitor. (Civ5)
I have three identical Iiyama XB2380HS - each of which can use HDMI, DVI, or VGA/D-Type.

Anyway - nothing I can do will get the third port (VGA) on my card working and I don’t know if it is a hardware failure or driver, or what.

I am using the latest proprietary drivers from NVidia - 346.59 - and the symptoms are that running nvidia-settings and the system-settings “Detect Displays” results in nothing appearing on the display connected to the VGA port. (I’ve tried two cables and two monitors to eliminate hardware failure there. The VGA cable works fine with a laptop) The HDMI and DVI connecrted displays seem fine.

I am running Ubuntu 15.04 64-bit desktop.

I can’t see how to attach my full nvidia-bug-report.log.gz, but here is a relevant section.

[ 12.255] (II) NVIDIA(0): Detected PCI Express Link width: 8X
[ 12.256] (–) NVIDIA(0): Valid display device(s) on GeForce GT 720 at PCI:1:
0:0
[ 12.256] (–) NVIDIA(0): Idek Iiyama PLX2380H (DFP-0) (boot, connected)
[ 12.256] (–) NVIDIA(0): Idek Iiyama PLX2380H (DFP-1) (connected)
[ 12.256] (–) NVIDIA(0): Idek Iiyama PLX2380H (DFP-0): Internal TMDS
[ 12.256] (–) NVIDIA(GPU-0): Idek Iiyama PLX2380H (DFP-0): 330.0 MHz maximum pixel clock
[ 12.256] (–) NVIDIA(0): Idek Iiyama PLX2380H (DFP-1): Internal TMDS
[ 12.256] (–) NVIDIA(GPU-0): Idek Iiyama PLX2380H (DFP-1): 340.0 MHz maximum pixel clock
[ 12.256] () NVIDIA(0): Using HorizSync/VertRefresh ranges from the EDID for display
[ 12.256] (
) NVIDIA(0): device Idek Iiyama PLX2380H (DFP-0) (Using EDID
[ 12.256] () NVIDIA(0): frequencies has been enabled on all display devices.)
[ 12.257] (
) NVIDIA(0): Using HorizSync/VertRefresh ranges from the EDID for display
[ 12.257] () NVIDIA(0): device Idek Iiyama PLX2380H (DFP-1) (Using EDID
[ 12.257] (
) NVIDIA(0): frequencies has been enabled on all display devices.)

Do I need to do anything to make it detect the third monitor?

nvidia-bug-report.log.gz (81.3 KB)

attached bug-report

If you just do two monitors, DVI + VGA, does it work?

If you just do two monitors, DVI + VGA, does it work?

No - which is the most suspicious thing. Presumably that suggests hardware failure

Well this is embarassing. After a few more restarts and swapping cables it has started to work.

Hi! can you paste your xorg.conf file?

I’m trying to configure a GT610 (DVI/HDMI/VGA) with three monitors but I only can use two monitors at same time. DVI/HDMI (depending driver) monitor is detected but can not be enabled.

With open drivers, I can enable the HDMI and DVI and with 346.59 I can enable the DVI and VGA but not all at time.

My xrandr show this (with two monitors):

$ xrandr -q                                                                                                     
Screen 0: minimum 8 x 8, current 3840 x 1080, maximum 16384 x 16384
DVI-I-0 disconnected (normal left inverted right x axis y axis)
VGA-0 connected primary 1920x1080+1920+0 (normal left inverted right x axis y axis) 510mm x 290mm
   1920x1080      60.0*+
   1680x1050      60.0  
   1600x1200      60.0  
   1440x900       59.9  
   1280x1024      75.0     60.0  
   1280x960       60.0  
   1152x864       75.0  
   1024x768       75.0     70.1     60.0  
   800x600        75.0     72.2     60.3     56.2  
   640x480        75.0     72.8     59.9  
DVI-I-1 disconnected (normal left inverted right x axis y axis)
HDMI-0 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 510mm x 290mm
   1920x1080      60.0*+   59.9     50.0     60.1     60.0     50.0  
   1680x1050      60.0  
   1600x1200      60.0  
   1440x900       59.9  
   1280x1024      75.0     60.0  
   1280x960       60.0  
   1280x720       60.0     59.9     50.0  
   1152x864       75.0  
   1024x768       75.0     70.1     60.0  
   800x600        75.0     72.2     60.3     56.2  
   720x576        50.0  
   720x480        59.9  
   640x480        75.0     72.8     59.9     59.9

Thanks for your help :)

I think the GT 610 is a Fermi card and therefore can only display two monitors at a time.