Timeout: Pulling device files

When trying to debug a build running on emulator, the debugger startup process times out while “Pulling device files”.
It looks like it is pulling the entire libs directory (~55 MB) from the remote target:

adb.exe" -s emulator-5554 pull “/system/lib/” “C:\Users\xxxx\AppData\Local\Temp\Android\emulator-5554\system/lib/”

This operation just about completes before the timeout time for hardware devices but is slow enough to fail on the emulators. I also can’t seem to find an option to increase this timeout wait.

A couple of Qs:
1/ Why is it necessary to copy all the system libraries to the host PC, in order to start a debugging session?
2/ Is there a fix or workaround pending?


-Paul Martin [Slant Six Games]

I have the same problem. Is there any solution ?

you can set remote time longer in VS: Tools>options>Android>Debug>Remote timeout

I’m having this same problem. I’m dead in the water. I’ve increased the timeout and it still times out in about the same time no matter what I set.

I’m just trying to debug the nvidia basic native app.

It pulls the whole lib folder over even if the lib folder has ALREADY been copied over to the host machine. When you restart the debugger session, it wipes the lib folder and starts over again. It fails to debug if it can’t wipe the lib folder.

How about releasing the source for the DLL you use for the debugging interface so we can fix it?

which version do you use? I tried on VS2010 on win7_64 and failed to reproduce this issue.

  1. with default timeout. it works normally.
  2. when it had pulled the files, it won’t pull them again.
  • Window 8 64 bit.

  • Visual Studio 10 with latest service patch.

  • Fresh install of the devpack. I’m not clear how to determine the version but, it’s the most current you have on your site.

  • Using an emulator image of the Nexus 7 Android 4.2.2 armabi v7a

I’ve worked on it some more over the weekend. Using a real Nexus 7, it works. Using a real device it doesn’t try to pull device files. Under the emulator, I can watch it pull the files, slowly off the device to my hard disk. It just never finishes before it times out.

we recommend to use the real device when doing native development. and TADP is only guaranted on Tegra device.