Timestamp problem in deepstream splitmuxsink with matroskamux

Please provide complete information as applicable to your setup.

• Hardware Platform DGPU
• DeepStream Version 6.0.1
• NVIDIA GPU Driver Version 510.85.02
• Issue Type( questions, new requirements, bugs)
I’ve been using splitmuxsink to split the recordings of a live video stream by length or by the “split now” cmd. The resulting video files are all timestamped with the “global time” from when the pipeline started.

File1 00:00 - 05:00

File2 05:00 - 10:00

File3 10:00 - 15:00

This is causing issues when playing back the files in certain video players that are expected a time stamp starting at 0.

What I’d like to do is reset the time stamping every time the recordings are split and a new file is started.

File1 00:00 - 05:00

File2 00:00 - 05:00

File3 00:00 - 05:00

can you help me to resolve this issue?

• How to reproduce the issue ? (This is for bugs. Including which sample app is using, the configuration files content, the command line used and other details for reproducing)

my pipeline

• Requirement details( This is for new requirement. Including the module name-for which plugin or for which sample application, the function description)

it an continuation of this Changing filesink location in probe function - #10 by gowtham2 forum
can you help me to resolve this issue?

@fanzh give this link
matroskamux is in gst-plugins-good module, you can rebuild gst-plugins-good , please refer to Gstreamer build doc, README · discontinued-for-monorepo · GStreamer / gst-plugins-good · GitLab

I download gst-plugins-good-1.19.1.tar.xz file and extract it.

when I run meson build, I got error

Dependency gstreamer-1.0 found: NO found 1.14.5 but need: ‘>= 1.19.0’
Found CMake: /usr/bin/cmake (3.10.2)
Run-time dependency gstreamer-1.0 found: NO (tried pkgconfig and cmake)
Looking for a fallback subproject for the dependency gstreamer-1.0

meson.build:246:0: ERROR: Neither a subproject directory nor a gstreamer.wrap file was found.

meson-log.txt (41.1 KB)

My gstreamer version - 1.14.5, how to rebuild gst-plugins-good to resolve timestamp issue.

here is the code repo: GStreamer / gstreamer · GitLab

it is possible to rebuild gst-plugins-good-1.19.1 with gstreamer-1.14.5

This issue would be outside of Deepstream, You could try asking in the gstreamer Github or community.
from my experience, gst-plugins-good is based on some base libs, you can clone all gstreamer code if don’t know which libs need to clone, then modify the code, rebuild, replace gst-plugins-good lib.

how to suppress or ignore this warning?
(python3:12586): GStreamer-CRITICAL **: 16:26:12.568: gst_buffer_resize_range: assertion ‘bufmax >= bufoffs + offset + size’ failed

this bug was fixed, please try deepsream 6.1.1/ 6.2.

for jetson nano, the available deepstream version is 6.0.1
is it possible to update deepstream 6.1

please refer to Quickstart Guide — DeepStream 6.2 Release documentation
as the data shown, deepstream 6.1dose not support Nano.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.