Titan X not appearing in lspci output

I have been successfully running a GTX690 for a while in my machine. I threw in my shiny new Titan X today and it’s not appearing in lspci output at all.

I am using a 600W power supply, which I believe should be sufficient.

I only have 8G RAM in this machine, though, which I believe may be insufficient. Would this prevent the device from even showing up, though, or just degrade performance? I have more RAM on its way but would like to better understand the problem in the mean time.

It’s not a RAM issue. It may be an incompatibility with the motherboard and the GPU, you may want to try a BIOS update on the motehrboard. It may also be a power delivery issue. It may be that you have the GPU plugged into the wrong slot. It might be a defective GPU or motherboard.

If you are running both the GTX 690 and the Titan X in a system with a 600W PSU, you likely have an issue with insufficient power. Rule of thumb: Total combined nominal wattage of all components in the system should be 50%-60% of nominal PSU wattage.

Thanks for the comments. I am not running both cards on the 600W – I removed the GTX690 before installing the Titan X. (I also flashed the OS and started from scratch).

I’ll investigate potential motherboard incompatibility – this was another thing I was wondering (it’s an old-ish, rather cheap board).

Dear All,

I am also trying to get the Titan X going with my 6 months old Supermicro (hope bios is pretty up-to-date) running Ubuntu 14.04.5.

Couple general questions:

  1. Without installing any specific NVidia drivers, I assume I only see the basic VGA and Audio as below, right:
    83:00.0 VGA compatible controller: NVIDIA Corporation Device 1b00 (rev a1)
    83:00.1 Audio device: NVIDIA Corporation Device 10ef (rev a1)

  2. When installing NVIDIA-Linux-x86_64-370.23_for_Titan_X_card.run, it has an error:
    ERROR: Unable to load the ‘nvidia-drm’ kernel module.
    Do people have this problem and how to overcome?



Follow the instructions in the linux install guide carefully.

Thanks txbob! I downloaded the .deb instead of the .run. Everything works now!

Well, I’ve dramatically upgraded the surrounding hardware, and the card still doesn’t seem to be fully available. I’ve built a new box from scratch with a very new motherboard (Asus X99 Deluxe).

I can use the card as a basic VGA output for, e.g., BIOS config, installing the OS. But when I run lspci | grep -i nv all I see is

04:00.0 VGA compatible controller: NVIDIA Corporation Device 1b00 (rev a1)

I would expect some more specifics about the hardware in there, as I would see previously with the GTX690.

Any ideas? Thanks for all the help so far!

Ahh I ran sudo update-pciids and now I can see it. That whole “Follow the instructions in the linux install guide carefully.” thing…thanks again!