TitanV and NSight 5.5 --> Legacy debugger does not hit break points


I have a Titan V and K620 in my PC (both are in WDDM).
Running Win7/64 with SP1 and Dev Driver 390.65 and CUDA 9.1 (with the cuda blas patch)
I am running NSight 5.5.

I have been using Keras over CNTK on my TitanV for 2 months. No problem.
Command line nvprof works just fine.

When I run VS 2015, on a debug build of the sdk app vectorADD (by the way, I added cudaDeviceReset() at the end) …

  1. If I run START CUDA DEBUG (legacy) … I can’t hit a breakpoint in the kernel.

I get this message.

Adapter: TITAN V
A CUDA context was created on a GPU that is not currently debuggable. Breakpoints will be disabled.

  1. if I run the START PERFORMANCE analysis …I get … “No kernel events captured”.

I rerun the experiment under VS 2017 – same results! (but remember… the nvprof works fine).

What am I doing wrong?

Why doesn’t the bp trigger?
Why can’t I capture kernel launches for the performance analyzer?


Legacy debugger doesn’t support TitanV, you shall use the next-gen debugger