Tk1 and stepper motor

I am trying to drive a stepper motor with the Jetson Tk1 and I am running into problems.

I am using a polulu driver, https://www.pololu.com/product/1182 with A4988 chip.

I have followed the GPIO examples and I can turn off/on a LED with Jetson Tk1 OK both form the command line, python and c++
The wiring, driver and motor work OK with my Raspberry PI and even with everything (direction, reset pins, VCC) connected to the Jetson and driving the stepper pin (though the transistor switch) with the RaspPi.

But if I connect the stepper pin (through the transistor switch) to Jetson GPIO the motor moves with very strange behaviour.
I am missing something about the difference between jetson GPIO and RaspPi GPIO.
Thanks

Is RaspPi GPIO 3.3V? Jetson TK1 is 1.8V…the TK1 pull-up resister could have optionally been designed for 3.3V or 5V, but 1.8V is what it is wired for. If this is the case, a level converter such as this would work:
https://www.sparkfun.com/products/11771

Thanks, yes I am using a logic level converter (I have also tried using a BC547 transistor). I have also tested with a multimeter and I am able to switch on an off at the right voltage (5v).
But the stepper motor still doesn’ tmove correctly…
Any other pointers?

Sometimes the wiring is an issue if the frequency is high enough, e.g., twisting of some wires with ground or their +/- counterparts reduces noise (the motor probably doesn’t care, but other components will). What’s the quality of the physical wiring?

Thanks again.
I am using a protoboard and new jumper wires. I will check that out, but with the same cables and just changing one connection from the Jetson to the RaspPi everything works fine…

You may want to wrap a ground wire around each wire as a twisted pair and try again. There’s no telling when noise or cross-talk will be an issue, and it’s easy to do. Otherwise you might need an oscilloscope or logic analyzer to see what’s going on.