TK1 black screen after update

My device is new. I went to terminal and did and was able to get into Ubuntu. Once in I ran an update. It mentioned a partition error. I rebooted my machine and it is black screened. I only have the terminal. I tried uninstalling and reinstalling lightdm amongst several other things. What should I do? Helpline reference number is 200409-000649

In short:

  • Upgrading ubuntu from Jetson is a bad idea.
  • You would clone your APP partition with same JetPack version, so that you would be able to loopback mount the image on host and get back your work and data
  • Then you would reflash your TK1, use latest JetPack version supporting TK1 and never upgrade Ubuntu version (you would apt update/upgrade in your current version)

What commands do I run? I can connect to the internet and get to terminal now. I’ve seen videos on it but no one has used just the terminal to do this.

Sorry, I haven’t played with TK1 since years ago, but you might try to follow this.
Be sure to clone with same Jetpack version you’ve used to flash. Your TK1 should be set in recovery mode for cloning.

It won’t let me passed the first step. No such file or directory exists. I formatted the sd and placed an older version of JetPack and put in on the tk1.

Can I get a reference number to replace it?

I don’t think it even recognizes the sd. I have tried several cards and ls command won’t pick it up. Can’t even get passed the first step here.

It also won’t let me into recovery mode

Doesn’t this work ?

Connect the Jetston TK1 to the host Linux computer via the micro-usb cable, and place the Jetson TK1 into recovery mode (by holding down the hardware Recovery button on the board and either pushing the Reset button if power is already plugged in, or plug in power for the first time).

Run lsusb on your host computer and make sure you see some kind of NVIDIA device

It does not. Just shows a black screen with no loading.

It is normal in recovery mode. Your TK1 would just be a USB device seen from host (check from host with lsusb). Then you can clone or reflash.
In your case I’d suggest to first clone and try to loopback mount the image, so that you can find back your data.
Once done you would try to reflash with latest JetPack supporting TK1.

There are actually two possible issues here. The first, which I don’t think you ran into, is that if you run a release upgrade (e.g., to go for Ubuntu 14.04 to Ubuntu 16.04), then this will cause failure. The second is that sometimes the OpenGL driver from NVIDIA gets overwritten by the Nouveau driver. This latter case is probably what occurred if you still have ssh or serial console access.

Can you get in via ssh or serial console? If so, then this is easy to fix. The command “sha1sum -c /etc/nv_tegra_release” will check for the NVIDIA-specific drivers, and I will bet that this will have a failed checksum (if not, then this is not an issue for you and you can skip the rest):

/usr/lib/xorg/modules/extensions/ OK

Notice that this is just a copy or symbolic link of “/usr/lib/arm-linux-gnueabihf/tegra/”. Thus if you have a bad “/usr/lib/xorg/modules/extensions/”, then overwrite it (or force sym link over this) using the reference file “/usr/lib/arm-linux-gnueabihf/tegra/”. Example:

sudo cp -f /usr/lib/arm-linux-gnueabihf/tegra/ /usr/lib/xorg/modules/extensions/


sudo ln -sf /usr/lib/arm-linux-gnueabihf/tegra/ /usr/lib/xorg/modules/extensions/

I think in the last (or nearly last) release for the TK1 this was fixed, but not sure.

Ive been able to set my tk1 in recovery mode. I installed ubuntu 14.04 on my old pc to run the commands. I followed the script and there is no bootloader. I have been trying to flash with jetpack but each option i try is either for tx1 or if it is for the tk1 the options pull up blank and i cant continue with the setup. The previous reply diagnostic came back ok.

I have never flashed my tk1 before so I don’t have the boot loader or anything established. I’m guessing I have to run the flash and then after do the cloning. Any input helps as I am new to this. I have found some resources online however I am still getting a blank set of options for the JetPack once it is pulled up. No flash is available. Maybe I have to be connected to the internet I’m not sure.

It sounds like you are unable to run the “sha1sum -c /etc/nv_tegra_release” command. Is that correct? Also, that you do not have ssh or serial console access. Is this correct? These change a number of steps as to what you can or must do next.

Being able to reach recovery mode shows basic function still exists, and that you can clone and/or flash.

Do you need to save a clone for work you cannot afford to lose?

If you just want to flash, then you can do this on command line. R21.8 is the most updated release possible, and this even requires command line to install (this is a patch release…you can then use the earlier JetPack3.1 to install optional package after flash is complete after unchecking flash since you would want apps, but you’d have already flashed R21.8).

FYI the R21.8 (command line only) is here:

If you choose to flash on command line, then the steps go like this on a host PC with a lot of spare disk space:
Unpack the “driver package” as a regular user. This creates a “Linux_for_Tegra/” subdirectory.

  1. Go to “Linux_for_Tegra/rootfs/”, and then unpack the “sample rootfs” with sudo.
  2. cd back to “Linux_for_Tegra/”, and run:
    sudo ./
  3. Place the TK1 in recovery mode with micro-B USB connected, verify with seeing content from:
    lsusb -d 0955:7140
  4. Run command:
    sudo ./ jetson-tk1 mmcblk0p1

In R21.x there was no need to do first boot setup, and should already have account/password “ubuntu”/“ubuntu” and “nvidia”/“nvidia”. If this is exposed to any public networking you should immediate change passwords.

Do keep in mind you want to use only an HDMI monitor for video.

If this succeeds, then you can run JetPack3.1 (L4T R21.5 through R21.8 were compatible patch releases), deselect flash, and see if you can add just the CUDA content as a test to the fully booted Jetson through wired ethernet. Do keep in mind that in some of these earlier releases that upon boot there is an automatic update of the packages, and this can lock you out from adding packages until it is done (and this can take a long time).

Should command line flash fail, then there is possibly something wrong in hardware, but you can never say boot fails via HDMI monitor failing. This is the realm of serial console, and sometimes that of ssh.