TK1 GUI wont start

Good day everyone

I’ve been working on getting UHD and GNU radio installed on the tegra tk1 and managed to get it to detect my B210 board, I however rebooted the system and now the GUI wont start. It flashes the boot sequence on the screen before going blank, I can still ssh into it and run everything normally. When I run sha1sum -c /etc/nv_tegra_release everything returns with ok. I did corrupt the file but created a new one, so I dont know if maybe it has something to do with that. I’ve also run startx but it doesnt do anything.

Thanks in advance for any help.

/var/log/Xorg.0.log might give some insight in why the GUI won’t start.

If your is wrong, then it might not find the correct Tegra specific libraries the X.Org driver fails to start. I recommend that you download the rootfs from the release page and check the content of the file.

Awesome thanks for the idea kulve! I tried populating the file with what I thought should be in there but getting the file from rootfs and running ldconfig did the job.