TK1 stuck on load

i got the TK1 on preorder when it was unveiled for a project than it was in a drawer for a couple of years and now when i got it out for another project it is stuck.
last line is
1.342719] serial8250.0: ttyS0 at MMIO 0x70006300 (irq = 122) is a Tegra
this is still on 2/3 of the screen displayed and the end 1/3 is still black so it is stuck in the early stages of loading.
also clicking the recovery or power buttons do noting and the TK1 is powering up on power supply connection.
keyboard seems dead with its num caps and scroll not indicating power nor is a USB driver that has a blink light on it.
also i do find 1 paragraph strange.
its within the 10th paragraph that says:
0.704082] tegradc tegradc.0: DSI: Failed to get chip info
Power on LED is active, fan is active, RJ-45 has an orange LED active.

also i just noticed another 2 rows ~5th row saying:
0.694174] pwm-backlight pwm-backlight: unable to request PWM, trying legacy API
0.694284] sysedp_create_consumer: unable to create pwm-backlight, no consumer_data for pwm-backlight found

i think the recovery might work cause the display does not power up than but i need to download and install VM and ubunto to check this out…
ps… i fucking hate linux :(

A VM mostly won’t work for flashes. A VM “can” work, but expect difficulties, e.g., the Jetson must be in recovery mode when the VM is started and the USB port bound to the VM. Basically, the USB of a VM is very unreliable and has lots of steps (which I don’t know all of) needing adjustment for it to stand a chance of working.

Recovery mode implies holding down the recovery button either during power up or during power reset. When this happens the micro-B USB connector becomes a custom USB device which the driver package understands (driver package goes on the host and JetPack can be used as a front end to the driver).

Should recovery mode work, the Linux PC will see the custom device via:

lsusb -d 0955:7140

It wouldn’t be unusual for video to make it look like a failure when it is really running, but the USB keyboard not responding tends to validate actual failure. Do you have a 9-pin D-sub serial cable for the serial port? This is a great debug tool because it works even in the boot loader and even when video and most of the system fails.

erm playing with the VM but i cant find the tegra from removable devices menu
however using the lsusb -d 0955:7140 you gave me on entering it it didnt give any info on switching to the tegra but it also didnt give an error when i entered it…
sorry my linux is… beyond 0
and no i dont have any other cables

USB has at one end of the cable a host, and at the other end a device. You can’t connect host-to-host or device-to-device, it must be host-to-device. lsusb lists devices when you are on a host. “lsusb -d 0955” lists any NVIDIA devices, “lsusb -d 0955:7140” lists NVIDIA Jetson TK1s. If the TK1 is in recovery mode and using that micro-B USB cable, then the host should see it…if not in recovery mode or if using the wrong cable type you can expect lsusb to not see the recovery mode Jetson.

Recovery mode can probably be seen by Windows too if you find the right GUI, but there is no driver in Windows, so Windows can’t do anything with it. It would be a good test though of if your system can see the Jetson without the VM in the way.

VMs are known for extreme frustration when it comes to binding the Jetson to the VM and making sure it passes through. If there is hardware failure this will of course be even more frustrating :P. But if you know your Jetson is in recovery mode, then and only then should you start up your VM and before starting use whatever software you have to find the Jetson and bind it to the VM. I have no idea how your VM is configured, but that is the gist of what needs to be done.

Note that a recovery mode Jetson uses USB2 mode…USB3 and previous slower USB modes do not work for this. So if you find a setting for forcing to USB2 mode you might also try that.

strangely i opened device manager on windows a few times and it doesnt seem to find the mUSB>USB connection
but when i boot or reboot the TK1 while holding the recovery button the display and the RJ-45 are offline so i am guessing it must be entering recovery mode.
i will have to copy paste some of the commands or atleast the lsusb one and shut down my system to install direct linux to try with no VM.
also i did try a few times playing with the USB2.0 3.0 port on my PC and i also swapped between USB 2.0 and 3.0 on the VM settings aswell…
i also updated the Ubuntu when i first installed it on the VM
it was originally 14.04.1 on my 1st 5 attempts before i updated it.
i did also try to lick the USB on the PC side to try and see if it will shot me cause somehow i have the feeling the god damn USBs arent working :(

the update is as it follows…
windows device manager cant indicate USB connection in any kind with the TK1
VM linux cant indicate any lsusb connection with TK1
linux from USB boot with no install locates all USBs connected accept TK1
installed on HDD linux same as USB boot linux…
Tested with 2 cables and changed 4 ports for each test with shutdown and recovery boot on the TK1
each non TK1 boot just ends on the (irq = 122) is a Tegra row
each recovery boot on the TK1 disables HDMI and LAN led indication.

i will try to find a USB>COM cable or a COM/COM cable with a COM PCI/PCIE board…

another update…
i also tried the linux on my 2nd PC same, finds all connected USBs accept the micro port on the TK1…
i also decided to test the full USB port with the micro cable to charge my phone and atleast it indicated slow charging so atleast the full USB port should be working…

Just to be certain, the steps to go to recovery if the Jetson is already off is to hold down the recovery button and tap the on button. Or, if power is already on, hold down the recovery button, then tap the reset button. Recovery must be held while power starts or resets…other than this there is no time requirement for how long the recovery button must be held.

If you cannot reach recovery mode I believe there is hardware failure. Keep in mind if you don’t have a type “B” on the micro-USB port you’ll never see a “device”…type “A” would be for a host mode.

The definitive test will be to see the serial port output. This runs at setting 115200, 8N1. You might try both with and without CTS/RTS flow control (I use flow control, it isn’t mandatory, not all serial cables support this).

well i did both depending how many tests i did but.
sometimes i held the recovery on power on sometimes i held it on reset
at the minimum each time i held the recovery pressed for 1-2+ sec
as i said when recovery engages the HDMI has no output and the RJ-45 disables its orange led, so that makes me think at the minimum it is at some stage of entering recovery mode
about the cables…
1 was used for charging my phone and to connect it to my PC for picture/music transfer and my phone
2 was used for charging my Logitech G933 headset

thank you for your responses and i will post a feedback when i manage to find a cable cause… ill probably go to my ex employer where he had a ton of COM>COM COM>Eth COM>USB but… its gonna be a bitch to find a working one :D

back with info in 2 weeks…
god damn whole country doesnt have COM cables…

FYI, charger cables are probably not valid. Many of them are made less expensive to charge by eliminating some of the wires. Most of the cables which are valid have a small letter ‘B’ on the micro-USB connector end (sometimes brand name cables don’t add the letter so they can add their own graphics). The cable the JTK1 ships with is a type “B”, but it sounds like this is probably long lost. In any case I would expect 100% failure with charger cables to be the case even if the Jetson functions.

sadly the charging cable i got for my phone that was intended for car charging was 10 euro and has a big B on the micro side.
and has a pretty fat outer skin so i am guessing the wires have enough capacity.
oh well doesnt really matter…
i have to wait for the stupid shops to get COM cables cause for 2 days the only COM cable i found was male to USB with fucking 10 euro price tag and they didnt even have adapter to make it F

well finally found a 2nd hand cable and COM plug…
tried from windows putty Serial connect but noting is happening…
i will try from linux later…

PuTTy can be a bit difficult to make work. Be sure it is speed 115200, 8 bits, no parity, 1 stop bit, and initially try software flow control…if that works go to CTS/RTS hardware flow control.

One of the primary difficulties in PuTTy is just identifying which serial port to use.

triple and quad tried all 115200 8 no 1 on all settings and the serial is only 1
0 receive of anything…

Can’t help you much on that…I stick to Linux for development.