Tlt-converter for deepstream 4.0.2 for Jetson Nano


I am working with the Deepstream 4.0.2 that comes with the SD image provided from the DLI Deepstream Course. I’m wondering which version of the tlt-converter is competible with that particular version of Deepstream. I’ve tried the tlt-converet 7.1. I ran the tlt-converter -h command and got the following error:
./tlt-converter: error while loading shared libraries: cannot open shared object file: No such file or directory


Try this:

  1. Copy the executable to the target device
  2. Install openssl library using the following command.
    1. $ sudo apt-get install libssl-dev
  3. Export the following environment variables
    1. $ export TRT_LIB_PATH=”/usr/lib/aarch64-linux-gnu”
    2. $ export TRT_INC_PATH=”/usr/include/aarch64-linux-gnu”
  4. Run the converter

why not going with Deepstream5?

br, Martin

Please install deepsteam 5.0 in your Nano.

Thanks guys for your replies.

I use this version because it is a learning package comes with tutorial, sample and labs. Good for beginner like me to expeeriment with it.

I found that the installed TensorRT version is 6.0 and then I downloaded the from below. This version works for me.