tlt-dataconvert -r option

Hi,

I have a query related to ‘tlt-dataconvert -r’ option.

As the NGC model description mentioned:
[b]The data must be converted to 1mm resolution before training:

tlt-dataconvert -d {SOURCE_IMAGE_ROOT} -r 1 -s .nii.gz -e .nii.gz -o {DESTINATION_IMAGE_ROOT}[/b]

However, Dicom datasets have various dimensions with their relative resolutions. For example, a 512512100 with 0.75mm * 0.75mm * 1mm resolution dataset would not have the same shape as a 512512200 with 1mm * 1mm * 1mm resolution dataset after executing the ‘-r 1’ option.

Then training the model becomes impossible, since we don’t have uniform shape of the input samples.

I have tried to use Decathlon Lung data to train the lung segmentation model. It works fine if I do nothing to the raw dataset, but crashes if I run the ‘-r 1’ option since it changes the shape of each dataset.

Hi

Thanks for your interest in Clara train SDK.

We recommend you resample your data so it would be one less variation that model need to worry about/ learn. The input layer of the network would always expect the same image volume size that is why you would use a cropping transformation to this

  • CropSubVolumeBatchPosNegRatio
  • TransformVolumeCropROI
  • CropSubVolumeRandomWithinBounds
  • CropSubVolumeCenter

For full list of transformation and argument details, please see our documentation at:
https://docs.nvidia.com/clara/tlt-mi/tlt-mi-getting-started/index.html#data_transforms

Hope that helps

Thanks! It helps. Seems like I need to read the config_train.json file more carefully.

Thanks! It helps. Seems like I need to read the config_train.json file more carefully.