To recover Jetson TX2.


 While trying to interface SPI GPIO pins on my TX2 system stopped working, so I have to recover my data from TX2. I tried cloning and other ways but ended up with no result, so please suggest me a way to solve my issue.

Thanks in advance,

Surendra Allam.

What problem you would like to report here. SPI GPIO problem or cann’t recovery data?

I want to recover the data from TX2.

Did you backup your image? Below is some information for clone and restore it.

I followed it, but I couldn’t able to recover.

Did you hit what problem when you follow the wiki? Any error message? Please have detail information.

I completed successfully, but I tried starting it, it was rebooting continuously.

Try to flash the Image to original by below command.

sudo ./ -r -k kernel jetson-tx2 mmcblk0p1

FYI, if you clone an image from one release and then flash the clone into a different release, then there will probably be some boot failure. The same would be true if the non-rootfs partitions had been broken by previous operations even if the rootfs was the same release (if it was just a bad kernel then the above listed kernel flash would fix that). A full flash which names the clone and using the “-r” option to to reuse the rootfs would put things back to working condition since it also flashes non-rootfs partitions. Just be sure to keep your clone safe somewhere other than where you actually use it to flash in case something goes wrong…not using the “-r” option would overwrite your nice new clone.