Toggle the GPIO in Jetson Orin nano using Jetpack 6.0 (L4T_36_3)

Hi,

I’m trying to configure the CAM0_PWDN pin as output state and toggle the output using gpiod commands.

Followed the steps mentioned in the developer guide and changed the CAM0_PWDN pin state in Pinmux excel sheet.

https://docs.nvidia.com/jetson/archives/r36.3/DeveloperGuide/HR/JetsonModuleAdaptationAndBringUp/JetsonAgxOrinSeries.html#pinmux-changes

The below lines are added to the Pinmux and gpio dtsi files.

$ vim ./bootloader/generic/BCT/tegra234-mb1-bct-pinmux-p3767-dp-a03.dtsi
uart4_cts_ph6 {
nvidia,pins = “uart4_cts_ph6”;
nvidia,function = “rsvd1”;
nvidia,pull = <TEGRA_PIN_PULL_NONE>;
nvidia,tristate = <TEGRA_PIN_DISABLE>;
nvidia,enable-input = <TEGRA_PIN_DISABLE>;
nvidia,io-high-voltage = <TEGRA_PIN_DISABLE>;
nvidia,lpdr = <TEGRA_PIN_DISABLE>;
};

$ vim ./bootloader/tegra234-mb1-bct-gpio-p3767-dp-a03.dtsi
gpio-output-low = <
TEGRA234_MAIN_GPIO(H, 6)

Flashed the images into the orin nano developer kit using the below command

$ sudo ./flash.sh jetson-orin-nano-devkit mmcblk0p1

After that executed the below commands to toggle the pin with gpiod commands.

$ sudo gpioset 0 49=0
$ sleep 1
$ sudo gpioset 0 49=1

When I read back the value using gpioget command, the value is 0 and manually probed the pin to measure the voltage which is 0V.

test@test:~$ sudo gpioget 0 49
0

Can you please provide your suggestions to configure the CAM0_PWDN pin as output gpio in the Pinmux and toggling it using the gpiod commands.

@KevinFFF

Any help would be greatly appreciated.

You need to set the mode option for gpioset, or the effect is gone as soon as the process returns, which is too short for you to measure the voltage change.