Too many log entries from DSLOG using AMQP messages

Please provide complete information as applicable to your setup.

• Hardware Platform (Jetson / GPU)
Xavier AGX
• DeepStream Version
4.0
• JetPack Version (valid for Jetson only)
4.3
• TensorRT Version
• NVIDIA GPU Driver Version (valid for GPU only)
• Issue Type( questions, new requirements, bugs)

I’m using a derivative from deepstream-test4-app, and I’m getting my logs flooded with messages like:

Jan 15 11:36:05 areachica DSLOG[32462]: NVDS_AMQP_PROTO: nvds_msgapi_send_async: Send success
Jan 15 11:36:05 areachica DSLOG[32462]: NVDS_AMQP_PROTO: nvds_msgapi_do_work: Message sent = {#012  "version" : "4.0",#012  "id" : 368327,#012  "@timestamp" : "2021-01-15T14:36:05.190Z",#012  "sensorId" : "sensor-0",#012  "objects" : [#012    "-1|1794|276|1878|474|Person|#||0||||0"#012  ]#012}
Jan 15 11:36:05 areachica DSLOG[32462]: NVDS_AMQP_PROTO: nvds_msgapi_send_async: Send success
Jan 15 11:36:05 areachica DSLOG[32462]: NVDS_AMQP_PROTO: nvds_msgapi_do_work: Message sent = {#012  "version" : "4.0",#012  "id" : 368330,#012  "@timestamp" : "2021-01-15T14:36:05.769Z",#012  "sensorId" : "sensor-0",#012  "objects" : [#012    "-1|1740|276|1842|486|Person|#||0||||0"#012  ]#012}
Jan 15 11:36:05 areachica DSLOG[32462]: NVDS_AMQP_PROTO: nvds_msgapi_send_async: Send success
Jan 15 11:36:05 areachica DSLOG[32462]: NVDS_AMQP_PROTO: nvds_msgapi_do_work: Message sent = {#012  "version" : "4.0",#012  "id" : 368331,#012  "@timestamp" : "2021-01-15T14:36:05.975Z",#012  "sensorId" : "sensor-0",#012  "objects" : [#012    "-1|1656|288|1740|504|Person|#||0||||0",#012    "-1|1746|276|1830|486|Person|#||0||||0",#012    "-1|1788|204|1926|504|Person|#||0||||0"#012  ]#012}
Jan 15 11:36:06 areachica DSLOG[32462]: NVDS_AMQP_PROTO: nvds_msgapi_send_async: Send success
Jan 15 11:36:06 areachica DSLOG[32462]: NVDS_AMQP_PROTO: nvds_msgapi_do_work: Message sent = {#012  "version" : "4.0",#012  "id" : 368332,#012  "@timestamp" : "2021-01-15T14:36:06.183Z",#012  "sensorId" : "sensor-0",#012  "objects" : [#012    "-1|1632|288|1728|510|Person|#||0||||0",#012    "-1|1746|312|1830|504|Person|#||0||||0"#012  ]#012}
Jan 15 11:36:06 areachica DSLOG[32462]: NVDS_AMQP_PROTO: nvds_msgapi_send_async: Send success
Jan 15 11:36:06 areachica DSLOG[32462]: NVDS_AMQP_PROTO: nvds_msgapi_do_work: Message sent = {#012  "version" : "4.0",#012  "id" : 368333,#012  "@timestamp" : "2021-01-15T14:36:06.382Z",#012  "sensorId" : "sensor-0",#012  "objects" : [#012    "-1|1728|156|1866|504|Person|#||0||||0"#012  ]#012}
Jan 15 11:36:06 areachica DSLOG[32462]: NVDS_AMQP_PROTO: nvds_msgapi_send_async: Send success
Jan 15 11:36:06 areachica DSLOG[32462]: NVDS_AMQP_PROTO: nvds_msgapi_do_work: Message sent = {#012  "version" : "4.0",#012  "id" : 368335,#012  "@timestamp" : "2021-01-15T14:36:06.797Z",#012  "sensorId" : "sensor-0",#012  "objects" : [#012    "-1|1638|312|1722|510|Person|#||0||||0",#012    "-1|1716|312|1818|516|Person|#||0||||0",#012    "-1|1572|312|1656|504|Person|#||0||||0"#012  ]#012}

How can I disable these logs?

thanks

May I know why you want to disable it? it can give you failure log when something wrong happened, to identify in which part got wrong, also the log is in one file, not flooded onto standard output.

Sure, I’m processing video at 60fps, 7x24, so I have about 155M lines of logs each month, hitting on the internal flash. I would like to avoid that wear.

I’m ok with error or warning log, but these are just each and every message passed. It seems overkill.

Hi,
You can set log level to meet your case requirements, please check,
sources/tools/nvds_logger/setup_nvds_logger.sh
it have description about log level:
# Modify log severity level as required and rerun this script
# 0 Emergency: system is unusable
# 1 Alert: action must be taken immediately
# 2 Critical: critical conditions
# 3 Error: error conditions
# 4 Warning: warning conditions
# 5 Notice: normal but significant condition
# 6 Informational: informational messages
# 7 Debug: debug-level messages

1 Like

Thanks. That did the trick.

I have the same issue. I changed the value in line 61 from 7 to 0, but journalctl still shows the same messages.

Did you do any other change?

You need to rerun the script.

Hi,

yes, I did that. Sorry for not mentioning it. I also did a restart, although it was my understanding that that is not required, since the service is restarted within the script.

BTW: I assume there is a typo in the script in line 64:

rm -rf /etc/rsyslog.g/*-nvds.conf

That should be rsyslog.d, although this should not affect the function of the script.

Thanks

Yes, it doesn’t work.

It did for a while, but now it’s flooding again.

feb 01 10:12:38 areachica DSLOG[20821]: NVDS_AMQP_PROTO: nvds_msgapi_do_work: Message sent = {
                                          "version" : "4.0",
                                          "id" : 390222,
                                          "@timestamp" : "2021-02-01T13:12:38.578Z",
                                          "sensorId" : "sensor-0",
                                          "objects" : [
                                            "-1|240|75|300|273|Person|#||0||||0",
                                            "-1|300|72|363|267|Person|#||0||||0",
                                            "-1|369|75|426|258|Person|#||0||||0",
                                            "-1|414|72|477|261|Person|#||0||||0",
                                            "-1|471|57|537|267|Person|#||0||||0",
                                            "-1|195|81|255|273|Person|#||0||||0"
                                          ]
                                        }
feb 01 10:12:38 areachica DSLOG[20821]: NVDS_AMQP_PROTO: nvds_msgapi_send_async: Send success
feb 01 10:12:38 areachica DSLOG[20821]: NVDS_AMQP_PROTO: nvds_msgapi_do_work: Message sent = {
                                          "version" : "4.0",
                                          "id" : 390223,
                                          "@timestamp" : "2021-02-01T13:12:38.779Z",
                                          "sensorId" : "sensor-0",
                                          "objects" : [
                                            "-1|333|75|387|234|Person|#||0||||0",
                                            "-1|270|84|327|240|Person|#||0||||0",
                                            "-1|381|81|432|237|Person|#||0||||0",
                                            "-1|435|78|489|243|Person|#||0||||0",
                                            "-1|483|72|549|252|Person|#||0||||0"
                                          ]
                                        }

Too many logs.

It seems like filters in /etc/rsyslog.d/11-nvds.conf are ignored. I tried to set this file up in a way that all messages are discarded, but that also doesn’t work. rsyslog does look at the file, since I can get errors, if I put nonsense in 11-nvds.conf.

After set log level to another 0 from default 6, rerun the script i wait around 15 minutes, but i did not observe information log. nothing in the file.

Just change line 61, log level to another one you want, rerun the script.

echo “if ($msg contains ‘DSLOG’) and ($syslogseverity <= 6) then $nvdslogfilepath” >> 11-nvds.conf

to

echo “if ($msg contains ‘DSLOG’) and ($syslogseverity <= 0) then $nvdslogfilepath” >> 11-nvds.conf
// if you want to change to 0